# CVE-2024-27931: Insufficient permission checking in `Deno.makeTemp*` APIs

> Attackers can create files outside allowed directories via path traversal in Deno temp APIs, potentially overwriting system files.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-hrqr-jv8w-v9jh, JLSEC-2026-103

## What is CVE-2024-27931?

CVE-2024-27931 is a medium-severity path traversal vulnerability in denoland deno, published on 5 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deno is a JavaScript, TypeScript, and WebAssembly runtime with secure defaults. Insufficient validation of parameters in `Deno.makeTemp*` APIs would allow for creation of files outside of the allowed directories. This may allow the user to overwrite important files on the system that may affect other systems. A user may provide a prefix or suffix to a `Deno.makeTemp*` API containing path traversal characters. This is fixed in Deno 1.41.1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-27931?

2 open source packages ship an affected version, including deno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | All versions | 1.41.1 |
| `deno` | crates.io | All versions | 1.41.1 |

Products: Deno Deno.

## How do I fix CVE-2024-27931?

Upgrade deno to 1.41.1 or later.

## Is CVE-2024-27931 being exploited?

There is no known exploitation of CVE-2024-27931 in the wild and no public exploit code.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27931 and fix it if it is affected.

What it is: CVE-2024-27931 is a medium-severity path traversal vulnerability in denoland deno, published on 5 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27931 in the wild and no public exploit code.

Affected packages and fixed versions:
- deno (crates.io): affected all versions; fixed in 1.41.1
- deno (crates.io): affected all versions; fixed in 1.41.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27931/ (Markdown: https://insights.sbomify.com/CVE-2024-27931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27931
- OSV: https://osv.dev/vulnerability/CVE-2024-27931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27931/
Summaries are generated and may contain mistakes; the official description above is the record.
