# CVE-2024-27932: Deno's improper suffix match testing for DENO_AUTH_TOKENS

> Improper hostname matching in Deno's auth token handling may leak tokens to unintended domains when importing untrusted code.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-5frw-4rwq-xhcr, JLSEC-2026-104

## What is CVE-2024-27932?

CVE-2024-27932 is a medium-severity vulnerability in denoland deno, published on 6 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Deno is a JavaScript, TypeScript, and WebAssembly runtime. Starting in version 1.8.0 and prior to version 1.40.4, Deno improperly checks that an import specifier's hostname is equal to or a child of a token's hostname, which can cause tokens to be sent to servers they shouldn't be sent to. An auth token intended for `example[.]com` may be sent to `notexample[.]com`. Anyone who uses DENO_AUTH_TOKENS and imports potentially untrusted code is affected. Version 1.40.0 contains a patch for this issue

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-27932?

2 open source packages ship an affected version, including deno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | From 1.8.0 | 1.40.4 |
| `deno` | crates.io | From 1.8.0 | 1.40.4 |

Products: Deno Deno.

## How do I fix CVE-2024-27932?

Upgrade deno to 1.40.4 or later.

## Is CVE-2024-27932 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27932 exists.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27932 and fix it if it is affected.

What it is: CVE-2024-27932 is a medium-severity vulnerability in denoland deno, published on 6 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27932 exists.

Affected packages and fixed versions:
- deno (crates.io): affected from 1.8.0; fixed in 1.40.4
- deno (crates.io): affected from 1.8.0; fixed in 1.40.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27932/ (Markdown: https://insights.sbomify.com/CVE-2024-27932/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27932
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27932
- OSV: https://osv.dev/vulnerability/CVE-2024-27932

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27932/
Summaries are generated and may contain mistakes; the official description above is the record.
