{"answers":{"affected":"2 open source packages ship an affected version, including deno. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27935 exists.","fix":"Upgrade deno to 1.36.3 or later.","what":"CVE-2024-27935 is a high-severity vulnerability in denoland deno, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-27935 and fix it if it is affected.\n\nWhat it is: CVE-2024-27935 is a high-severity vulnerability in denoland deno, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27935 exists.\n\nAffected packages and fixed versions:\n- deno (crates.io): affected from 1.35.1; fixed in 1.36.3\n- deno (crates.io): affected from 1.35.1; fixed in 1.36.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27935/ (Markdown: https://insights.sbomify.com/CVE-2024-27935/index.md)","id":"CVE-2024-27935","markdown":"https://insights.sbomify.com/CVE-2024-27935/index.md","name":"CVE-2024-27935","record":{"aliases":["GHSA-wrqv-pf6j-mqjp"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Deno runtime","requires_auth":"none","summary":"Cross-session data contamination in Deno's Node.js compatibility layer allows attackers to read data from other sessions via shared buffers.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"deno","vendor":"deno"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-488","name":"Exposure of Data Element to Wrong Session"}],"description":"Deno is a JavaScript, TypeScript, and WebAssembly runtime. Starting in version 1.35.1 and prior to version 1.36.3, a vulnerability in Deno's Node.js compatibility runtime allows for cross-session data contamination during simultaneous asynchronous reads from Node.js streams sourced from sockets or files. The issue arises from the re-use of a global buffer (BUF) in stream_wrap.ts used as a performance optimization to limit allocations during these asynchronous read operations. This can lead to data intended for one session being received by another session, potentially resulting in data corruption and unexpected behavior. This affects all users of Deno that use the node.js compatibility layer for network communication or other streams, including packages that may require node.js libraries indirectly. Version 1.36.3 contains a patch for this issue.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Deno's Node.js Compatibility Runtime has Cross-Session Data Contamination","id":"CVE-2024-27935","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Deno interactive permission prompt spoofing via improper ANSI stripping","id":"CVE-2024-27936"},"packages":[{"ecosystem":"crates.io","fixed":["1.36.3"],"introduced":["1.35.1"],"last_affected":[],"package":"deno","purl":null,"source":"GHSA-wrqv-pf6j-mqjp"},{"ecosystem":"crates.io","fixed":["1.36.3"],"introduced":["1.35.1"],"last_affected":[],"package":"deno","purl":"pkg:cargo/deno","source":"GHSA-wrqv-pf6j-mqjp"}],"prev":{"headline":"*const c_void / ExternalPointer unsoundness leading to use-after-free","id":"CVE-2024-27934"},"products":["deno"],"published":"2024-03-06","related":[{"cvss_score":10,"headline":"Deno improperly handles resizable ArrayBuffer","id":"CVE-2023-28445","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":10,"headline":"Sandbox bypass leading to arbitrary code execution in Deno","id":"CVE-2022-24783","kev_date_added":null,"published":"2022-03-25"},{"cvss_score":9.8,"headline":"Static imports inside dynamically imported modules do not adhere to permission checks","id":"CVE-2021-32619","kev_date_added":null,"published":"2021-05-28"},{"cvss_score":9.2,"headline":"Deno node:crypto doesn't finalize cipher","id":"CVE-2026-22863","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":8.8,"headline":"Deno interactive permission prompt spoofing via improper ANSI stripping","id":"CVE-2024-27936","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":8.8,"headline":"Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization","id":"CVE-2023-28446","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":8.6,"headline":"Deno missing \"--allow-net\" permission check for built-in Node modules","id":"CVE-2023-33966","kev_date_added":null,"published":"2023-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["denoland"]},"summary":"Cross-session data contamination in Deno's Node.js compatibility layer allows attackers to read data from other sessions via shared buffers.","url":"https://insights.sbomify.com/CVE-2024-27935/"}