# CVE-2024-27935: Deno's Node.js Compatibility Runtime has Cross-Session Data Contamination

> Cross-session data contamination in Deno's Node.js compatibility layer allows attackers to read data from other sessions via shared buffers.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-wrqv-pf6j-mqjp

## What is CVE-2024-27935?

CVE-2024-27935 is a high-severity vulnerability in denoland deno, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deno is a JavaScript, TypeScript, and WebAssembly runtime. Starting in version 1.35.1 and prior to version 1.36.3, a vulnerability in Deno's Node.js compatibility runtime allows for cross-session data contamination during simultaneous asynchronous reads from Node.js streams sourced from sockets or files. The issue arises from the re-use of a global buffer (BUF) in stream_wrap.ts used as a performance optimization to limit allocations during these asynchronous read operations. This can lead to data intended for one session being received by another session, potentially resulting in data corruption and unexpected behavior. This affects all users of Deno that use the node.js compatibility layer for network communication or other streams, including packages that may require node.js libraries indirectly. Version 1.36.3 contains a patch for this issue.

Weakness: CWE-488 (Exposure of Data Element to Wrong Session)

## Which versions are affected by CVE-2024-27935?

2 open source packages ship an affected version, including deno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | From 1.35.1 | 1.36.3 |
| `deno` | crates.io | From 1.35.1 | 1.36.3 |

Products: Deno Deno.

## How do I fix CVE-2024-27935?

Upgrade deno to 1.36.3 or later.

## Is CVE-2024-27935 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27935 exists.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27935 and fix it if it is affected.

What it is: CVE-2024-27935 is a high-severity vulnerability in denoland deno, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27935 exists.

Affected packages and fixed versions:
- deno (crates.io): affected from 1.35.1; fixed in 1.36.3
- deno (crates.io): affected from 1.35.1; fixed in 1.36.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27935/ (Markdown: https://insights.sbomify.com/CVE-2024-27935/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27935
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27935
- OSV: https://osv.dev/vulnerability/CVE-2024-27935

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27935/
Summaries are generated and may contain mistakes; the official description above is the record.
