{"answers":{"affected":"4 open source packages ship an affected version, including deno and deno_runtime. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27936 exists.","fix":"Upgrade deno to 1.41.0 or later.","what":"CVE-2024-27936 is a high-severity vulnerability in denoland deno, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-27936 and fix it if it is affected.\n\nWhat it is: CVE-2024-27936 is a high-severity vulnerability in denoland deno, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27936 exists.\n\nAffected packages and fixed versions:\n- deno (crates.io): affected from 1.32.1; fixed in 1.41.0\n- deno (crates.io): affected from 1.32.1; fixed in 1.41.0\n- deno_runtime (crates.io): affected from 0.103.0; fixed in 0.147.0\n- deno_runtime (crates.io): affected from 0.103.0; fixed in 0.147.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27936/ (Markdown: https://insights.sbomify.com/CVE-2024-27936/index.md)","id":"CVE-2024-27936","markdown":"https://insights.sbomify.com/CVE-2024-27936/index.md","name":"CVE-2024-27936","record":{"aliases":["GHSA-m4pq-fv2w-6hrw","JLSEC-2026-105"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Deno runtime","requires_auth":"none","summary":"Malicious Deno programs can spoof permission prompts via ANSI injection, tricking users into granting unintended access.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"deno","vendor":"deno"},{"product":"deno_runtime","vendor":"deno"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-150","name":"Improper Neutralization of Escape, Meta, or Control Sequences"}],"description":"Deno is a JavaScript, TypeScript, and WebAssembly runtime with secure defaults. Starting in version 1.32.1 and prior to version 1.41.0 of the deno library, maliciously crafted permission request can show the spoofed permission prompt by inserting a broken ANSI escape sequence into the request contents. Deno is stripping any ANSI escape sequences from the permission prompt, but permissions given to the program are based on the contents that contain the ANSI escape sequences. Any Deno program can spoof the content of the interactive permission prompt by inserting a broken ANSI code, which allows a malicious Deno program to display the wrong file path or program name to the user. Version 1.41.0 of the deno library contains a patch for the issue.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Deno interactive permission prompt spoofing via improper ANSI stripping","id":"CVE-2024-27936","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"glpi Users emails enumeration","id":"CVE-2024-27937"},"packages":[{"ecosystem":"crates.io","fixed":["1.41.0"],"introduced":["1.32.1"],"last_affected":[],"package":"deno","purl":null,"source":"GHSA-m4pq-fv2w-6hrw"},{"ecosystem":"crates.io","fixed":["1.41.0"],"introduced":["1.32.1"],"last_affected":[],"package":"deno","purl":"pkg:cargo/deno","source":"GHSA-m4pq-fv2w-6hrw"},{"ecosystem":"crates.io","fixed":["0.147.0"],"introduced":["0.103.0"],"last_affected":[],"package":"deno_runtime","purl":null,"source":"GHSA-m4pq-fv2w-6hrw"},{"ecosystem":"crates.io","fixed":["0.147.0"],"introduced":["0.103.0"],"last_affected":[],"package":"deno_runtime","purl":"pkg:cargo/deno_runtime","source":"GHSA-m4pq-fv2w-6hrw"}],"prev":{"headline":"Deno's Node.js Compatibility Runtime has Cross-Session Data Contamination","id":"CVE-2024-27935"},"products":["deno"],"published":"2024-03-06","related":[{"cvss_score":10,"headline":"Deno improperly handles resizable ArrayBuffer","id":"CVE-2023-28445","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":10,"headline":"Sandbox bypass leading to arbitrary code execution in Deno","id":"CVE-2022-24783","kev_date_added":null,"published":"2022-03-25"},{"cvss_score":9.8,"headline":"Static imports inside dynamically imported modules do not adhere to permission checks","id":"CVE-2021-32619","kev_date_added":null,"published":"2021-05-28"},{"cvss_score":9.2,"headline":"Deno node:crypto doesn't finalize cipher","id":"CVE-2026-22863","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":8.8,"headline":"Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization","id":"CVE-2023-28446","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":8.6,"headline":"Deno missing \"--allow-net\" permission check for built-in Node modules","id":"CVE-2023-33966","kev_date_added":null,"published":"2023-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["denoland"]},"summary":"Malicious Deno programs can spoof permission prompts via ANSI injection, tricking users into granting unintended access.","url":"https://insights.sbomify.com/CVE-2024-27936/"}