# CVE-2024-27936: Deno interactive permission prompt spoofing via improper ANSI stripping

> Malicious Deno programs can spoof permission prompts via ANSI injection, tricking users into granting unintended access.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-m4pq-fv2w-6hrw, JLSEC-2026-105

## What is CVE-2024-27936?

CVE-2024-27936 is a high-severity vulnerability in denoland deno, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Deno is a JavaScript, TypeScript, and WebAssembly runtime with secure defaults. Starting in version 1.32.1 and prior to version 1.41.0 of the deno library, maliciously crafted permission request can show the spoofed permission prompt by inserting a broken ANSI escape sequence into the request contents. Deno is stripping any ANSI escape sequences from the permission prompt, but permissions given to the program are based on the contents that contain the ANSI escape sequences. Any Deno program can spoof the content of the interactive permission prompt by inserting a broken ANSI code, which allows a malicious Deno program to display the wrong file path or program name to the user. Version 1.41.0 of the deno library contains a patch for the issue.

Weakness: CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences)

## Which versions are affected by CVE-2024-27936?

4 open source packages ship an affected version, including deno and deno_runtime. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | From 1.32.1 | 1.41.0 |
| `deno` | crates.io | From 1.32.1 | 1.41.0 |
| `deno_runtime` | crates.io | From 0.103.0 | 0.147.0 |
| `deno_runtime` | crates.io | From 0.103.0 | 0.147.0 |

Products: Deno Deno, Deno Deno Runtime.

## How do I fix CVE-2024-27936?

Upgrade deno to 1.41.0 or later.

## Is CVE-2024-27936 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27936 exists.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2023-28446](https://insights.sbomify.com/CVE-2023-28446/): Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27936 and fix it if it is affected.

What it is: CVE-2024-27936 is a high-severity vulnerability in denoland deno, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27936 exists.

Affected packages and fixed versions:
- deno (crates.io): affected from 1.32.1; fixed in 1.41.0
- deno (crates.io): affected from 1.32.1; fixed in 1.41.0
- deno_runtime (crates.io): affected from 0.103.0; fixed in 0.147.0
- deno_runtime (crates.io): affected from 0.103.0; fixed in 0.147.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27936/ (Markdown: https://insights.sbomify.com/CVE-2024-27936/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27936
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27936
- OSV: https://osv.dev/vulnerability/CVE-2024-27936

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27936/
Summaries are generated and may contain mistakes; the official description above is the record.
