# CVE-2024-27938: SMTP Smuggling in Postal

> Attackers can spoof incoming emails via SMTP smuggling, bypassing sender authorization checks in Postal mail server.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Mar 2024
- **Updated:** 27 Aug 2024
- **Also known as:** GHSA-j42r-6c99-hqf2

## What is CVE-2024-27938?

CVE-2024-27938 is a medium-severity vulnerability in postalserver postal, published on 11 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Postal is an open source SMTP server. Postal versions less than 3.0.0 are vulnerable to SMTP Smuggling attacks which may allow incoming e-mails to be spoofed. This, in conjunction with a cooperative outgoing SMTP service, would allow for an incoming e-mail to be received by Postal addressed from a server that a user has 'authorised' to send mail on their behalf but were not the genuine author of the e-mail. Postal is not affected for sending outgoing e-mails as email is re-encoded with `<CR><LF>` line endings when transmitted over SMTP. This issue has been addressed and users should upgrade to Postal v3.0.0 or higher. Once upgraded, Postal will only accept End of DATA sequences which are explicitly `<CR><LF>.<CR><LF>`. If a non-compliant sequence is detected it will be logged to the SMTP server log. There are no workarounds for this issue.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2024-27938?

It affects 1 product.


Products: Postalserver Postal.

## How do I fix CVE-2024-27938?

No fix has been published for CVE-2024-27938 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-27938 being exploited?

There is no known exploitation of CVE-2024-27938 in the wild and no public exploit code.

## Other vulnerabilities in postalserver postal

- [CVE-2026-25529](https://insights.sbomify.com/CVE-2026-25529/): Postal has HTML injection / XSS in message view (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27938 and fix it if it is affected.

What it is: CVE-2024-27938 is a medium-severity vulnerability in postalserver postal, published on 11 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27938 in the wild and no public exploit code.

Affected product: postalserver postal. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27938/ (Markdown: https://insights.sbomify.com/CVE-2024-27938/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27938
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27938
- OSV: https://osv.dev/vulnerability/CVE-2024-27938

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27938/
Summaries are generated and may contain mistakes; the official description above is the record.
