{"answers":{"affected":"6 open source packages ship an affected version, including langchain and langchain-core. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28088 exists.","fix":"Upgrade langchain to a fixed version for your release line: 0.0.339 or 0.1.11.","what":"CVE-2024-28088 is a high-severity path traversal vulnerability in n/a, published on 3 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28088 and fix it if it is affected.\n\nWhat it is: CVE-2024-28088 is a high-severity path traversal vulnerability in n/a, published on 3 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28088 exists.\n\nAffected packages and fixed versions:\n- langchain (PyPI): affected all versions; fixed in 0.0.339\n- langchain (PyPI): affected all versions; fixed in 0.0.339\n- langchain (PyPI): affected all versions; fixed in 0.1.11\n- langchain-core (PyPI): affected all versions; fixed in 0.1.11\n- langchain-core (PyPI): affected all versions; fixed in 0.1.30\n- langchain-core (PyPI): affected all versions; fixed in 0.1.30\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28088/ (Markdown: https://insights.sbomify.com/CVE-2024-28088/index.md)","id":"CVE-2024-28088","markdown":"https://insights.sbomify.com/CVE-2024-28088/index.md","name":"CVE-2024-28088","record":{"aliases":["GHSA-h59x-p739-982c","PYSEC-2024-43","PYSEC-2024-45"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"LangChain Python library","requires_auth":"low_privilege","summary":"Attackers can exploit path traversal in LangChain to disclose API keys or execute remote code by controlling path parameters.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"langchain","vendor":"langchain"}],"cvss":{"score":8.1,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"},{"id":"CWE-31","name":"Path Traversal: 'dir\\..\\..\\filename'"}],"description":"LangChain through 0.1.10 allows ../ directory traversal by an actor who is able to control the final part of the path parameter in a load_chain call. This bypasses the intended behavior of loading configurations only from the hwchase17/langchain-hub GitHub repository. The outcome can be disclosure of an API key for a large language model online service, or remote code execution. (A patch is available as of release 0.1.29 of langchain-core.)","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2024-03-14","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-03-14T07:02:11Z","kind":"github_poc","ref":"https://github.com/levpachmanov/cve-2024-28088-poc","stars":0,"title":null}],"tier":"weaponised"},"has_fix":true,"headline":"LangChain directory traversal vulnerability","id":"CVE-2024-28088","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":6,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-28089"},"packages":[{"ecosystem":"PyPI","fixed":["0.0.339"],"introduced":["0"],"last_affected":[],"package":"langchain","purl":null,"source":"GHSA-h59x-p739-982c"},{"ecosystem":"PyPI","fixed":["0.0.339"],"introduced":["0"],"last_affected":[],"package":"langchain","purl":"pkg:pypi/langchain","source":"GHSA-h59x-p739-982c"},{"ecosystem":"PyPI","fixed":["0.1.11"],"introduced":["0"],"last_affected":[],"package":"langchain","purl":"pkg:pypi/langchain","source":"PYSEC-2024-43"},{"ecosystem":"PyPI","fixed":["0.1.11"],"introduced":["0"],"last_affected":[],"package":"langchain-core","purl":"pkg:pypi/langchain-core","source":"PYSEC-2024-45"},{"ecosystem":"PyPI","fixed":["0.1.30"],"introduced":["0"],"last_affected":[],"package":"langchain-core","purl":null,"source":"GHSA-h59x-p739-982c"},{"ecosystem":"PyPI","fixed":["0.1.30"],"introduced":["0"],"last_affected":[],"package":"langchain-core","purl":"pkg:pypi/langchain-core","source":"GHSA-h59x-p739-982c"}],"prev":{"headline":"Bonitasoft Runtime Community edition's contains an insecure direct object references vulnerability","id":"CVE-2024-28087"},"products":["n/a"],"published":"2024-03-03","related":[{"cvss_score":9.8,"headline":"Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library","id":"CVE-2023-39631","kev_date_added":null,"published":"2023-09-01"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36281","kev_date_added":null,"published":"2023-08-22"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38860","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38896","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-39659","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"langchain Code Injection vulnerability","id":"CVE-2023-36095","kev_date_added":null,"published":"2023-08-05"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36188","kev_date_added":null,"published":"2023-07-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-26","vendors":["n/a"]},"summary":"Attackers can exploit path traversal in LangChain to disclose API keys or execute remote code by controlling path parameters.","url":"https://insights.sbomify.com/CVE-2024-28088/"}