# CVE-2024-28088: LangChain directory traversal vulnerability

> Attackers can exploit path traversal in LangChain to disclose API keys or execute remote code by controlling path parameters.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2024
- **Updated:** 26 Aug 2024
- **Also known as:** GHSA-h59x-p739-982c, PYSEC-2024-43, PYSEC-2024-45

## What is CVE-2024-28088?

CVE-2024-28088 is a high-severity path traversal vulnerability in n/a, published on 3 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LangChain through 0.1.10 allows ../ directory traversal by an actor who is able to control the final part of the path parameter in a load_chain call. This bypasses the intended behavior of loading configurations only from the hwchase17/langchain-hub GitHub repository. The outcome can be disclosure of an API key for a large language model online service, or remote code execution. (A patch is available as of release 0.1.29 of langchain-core.)

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-31 (Path Traversal: 'dir\..\..\filename')

## Which versions are affected by CVE-2024-28088?

6 open source packages ship an affected version, including langchain and langchain-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain` | PyPI | All versions | 0.0.339 |
| `langchain` | PyPI | All versions | 0.0.339 |
| `langchain` | PyPI | All versions | 0.1.11 |
| `langchain-core` | PyPI | All versions | 0.1.11 |
| `langchain-core` | PyPI | All versions | 0.1.30 |
| `langchain-core` | PyPI | All versions | 0.1.30 |

Products: Langchain Langchain.

## How do I fix CVE-2024-28088?

Upgrade langchain to a fixed version for your release line: 0.0.339 or 0.1.11.

## Is CVE-2024-28088 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28088 exists.

Public exploit code:

- https://github.com/levpachmanov/cve-2024-28088-poc (github_poc): https://github.com/levpachmanov/cve-2024-28088-poc

## Other vulnerabilities in n/a

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28088 and fix it if it is affected.

What it is: CVE-2024-28088 is a high-severity path traversal vulnerability in n/a, published on 3 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28088 exists.

Affected packages and fixed versions:
- langchain (PyPI): affected all versions; fixed in 0.0.339
- langchain (PyPI): affected all versions; fixed in 0.0.339
- langchain (PyPI): affected all versions; fixed in 0.1.11
- langchain-core (PyPI): affected all versions; fixed in 0.1.11
- langchain-core (PyPI): affected all versions; fixed in 0.1.30
- langchain-core (PyPI): affected all versions; fixed in 0.1.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28088/ (Markdown: https://insights.sbomify.com/CVE-2024-28088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28088
- OSV: https://osv.dev/vulnerability/CVE-2024-28088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28088/
Summaries are generated and may contain mistakes; the official description above is the record.
