# CVE-2024-28098: Apache Pulsar: Improper Authorization For Topic-Level Policy Management

> Authenticated users with basic permissions can improperly modify topic-level policies, requiring an upgrade to patched versions.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-g627-r579-rw35

## What is CVE-2024-28098?

CVE-2024-28098 is a medium-severity missing authorization vulnerability in Apache Pulsar, published on 12 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role.

This issue affects Apache Pulsar versions from 2.7.1 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 

2.10 Apache Pulsar users should upgrade to at least 2.10.6.
2.11 Apache Pulsar users should upgrade to at least 2.11.4.
3.0 Apache Pulsar users should upgrade to at least 3.0.3.
3.1 Apache Pulsar users should upgrade to at least 3.1.3.
3.2 Apache Pulsar users should upgrade to at least 3.2.1.

Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-28098?

10 open source packages ship an affected version, including org.apache.pulsar:pulsar-broker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.11.0 | 2.11.4 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.11.0 | 2.11.4 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.7.1 | 2.10.6 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 2.7.1 | 2.10.6 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 3.0.0 | 3.0.3 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 3.0.0 | 3.0.3 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 3.1.0 | 3.1.3 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 3.1.0 | 3.1.3 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 3.2.0 | 3.2.1 |
| `org.apache.pulsar:pulsar-broker` | Maven | From 3.2.0 | 3.2.1 |

Products: Apache Pulsar.

## How do I fix CVE-2024-28098?

Upgrade org.apache.pulsar:pulsar-broker to a fixed version for your release line: 2.11.4, 2.10.6, 3.0.3 or 3.1.3.

## Is CVE-2024-28098 being exploited?

There is no known exploitation of CVE-2024-28098 in the wild and no public exploit code.

## Other vulnerabilities in Apache Pulsar

- [CVE-2021-22160](https://insights.sbomify.com/CVE-2021-22160/): Authentication with JWT allows use of “none”-algorithm (critical 9.8)
- [CVE-2023-30429](https://insights.sbomify.com/CVE-2023-30429/): Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy (critical 9.6)
- [CVE-2024-27135](https://insights.sbomify.com/CVE-2024-27135/): Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution (high 8.5)
- [CVE-2024-27894](https://insights.sbomify.com/CVE-2024-27894/): Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying (high 8.5)
- [CVE-2024-27317](https://insights.sbomify.com/CVE-2024-27317/): Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28098 and fix it if it is affected.

What it is: CVE-2024-28098 is a medium-severity missing authorization vulnerability in Apache Pulsar, published on 12 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28098 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.11.0; fixed in 2.11.4
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.11.0; fixed in 2.11.4
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.7.1; fixed in 2.10.6
- org.apache.pulsar:pulsar-broker (Maven): affected from 2.7.1; fixed in 2.10.6
- org.apache.pulsar:pulsar-broker (Maven): affected from 3.0.0; fixed in 3.0.3
- org.apache.pulsar:pulsar-broker (Maven): affected from 3.0.0; fixed in 3.0.3
- org.apache.pulsar:pulsar-broker (Maven): affected from 3.1.0; fixed in 3.1.3
- org.apache.pulsar:pulsar-broker (Maven): affected from 3.1.0; fixed in 3.1.3
- org.apache.pulsar:pulsar-broker (Maven): affected from 3.2.0; fixed in 3.2.1
- org.apache.pulsar:pulsar-broker (Maven): affected from 3.2.0; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28098/ (Markdown: https://insights.sbomify.com/CVE-2024-28098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28098
- OSV: https://osv.dev/vulnerability/CVE-2024-28098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28098/
Summaries are generated and may contain mistakes; the official description above is the record.
