CVE-2024-28102 JWCrypto vulnerable to JWT bomb Attack in `deserialize` function

Medium 6.8 Published Updated

An attacker can cause a denial of service by sending a malicious JWE token with high compression, exhausting server memory and processing time.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-28102?

CVE-2024-28102 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 6 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

JWCrypto implements JWK, JWS, and JWE specifications using python-cryptography. Prior to version 1.5.6, an attacker can cause a denial of service attack by passing in a malicious JWE Token with a high compression ratio. When the server processes this token, it will consume a lot of memory and processing time. Version 1.5.6 fixes this vulnerability by limiting the maximum token length.

Weakness: CWE-770

Which versions are affected by CVE-2024-28102?

3 open source packages ship an affected version, including jwcrypto. It affects 2 products.

PackageAffectedFixed in
jwcrypto PyPIAll versions1.5.6
jwcrypto PyPIAll versions1.5.6
jwcrypto PyPIAll versions1.5.6
Linux distribution packages (4)
python3-jwcrypto AlmaLinux:9All versions0.8-5.el9_4
python-jwcrypto Red Hat:enterprise_linux:9::appstreamAll versions0:0.8-5.el9_4
python3-jwcrypto Red Hat:enterprise_linux:9::appstreamAll versions0:0.8-5.el9_4
python-jwcrypto Rocky Linux:9All versions0:0.8-5.el9_4

Products include Debian Debian Linux, Latchset Jwcrypto.

How do I fix CVE-2024-28102?

Upgrade jwcrypto to 1.5.6 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-28102 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28102 exists.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALSA-2024:2559, AZL-43360, AZL-43366, DEBIAN-CVE-2024-28102, DLA-3883-1, GHSA-j857-7rvv-vj97 and 8 more.

Is CVE-2024-28102 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free