# CVE-2024-28102: JWCrypto vulnerable to JWT bomb Attack in `deserialize` function

> An attacker can cause a denial of service by sending a malicious JWE token with high compression, exhausting server memory and processing time.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 9 Sep 2024
- **Also known as:** ALSA-2024:2559, AZL-43360, AZL-43366, DEBIAN-CVE-2024-28102, DLA-3883-1, GHSA-j857-7rvv-vj97, OESA-2024-2444, OESA-2025-1163, PYSEC-2026-1484, RHSA-2024:2559, RLSA-2024:2559, ROOT-APP-PYPI-CVE-2024-28102, UBUNTU-CVE-2024-28102, openSUSE-SU-2024:13798-1

## What is CVE-2024-28102?

CVE-2024-28102 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 6 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

JWCrypto implements JWK, JWS, and JWE specifications using python-cryptography. Prior to version 1.5.6, an attacker can cause a denial of service attack by passing in a malicious JWE Token with a high compression ratio. When the server processes this token, it will consume a lot of memory and processing time. Version 1.5.6 fixes this vulnerability by limiting the maximum token length.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-28102?

3 open source packages ship an affected version, including jwcrypto. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jwcrypto` | PyPI | All versions | 1.5.6 |
| `jwcrypto` | PyPI | All versions | 1.5.6 |
| `jwcrypto` | PyPI | All versions | 1.5.6 |
| `python3-jwcrypto` | AlmaLinux:9 | All versions | 0.8-5.el9_4 |
| `python-jwcrypto` | Red Hat:enterprise_linux:9::appstream | All versions | 0:0.8-5.el9_4 |
| `python3-jwcrypto` | Red Hat:enterprise_linux:9::appstream | All versions | 0:0.8-5.el9_4 |
| `python-jwcrypto` | Rocky Linux:9 | All versions | 0:0.8-5.el9_4 |

Products: Debian Debian Linux, Latchset Jwcrypto.

## How do I fix CVE-2024-28102?

Upgrade jwcrypto to 1.5.6 or later.

## Is CVE-2024-28102 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28102 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28102 and fix it if it is affected.

What it is: CVE-2024-28102 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 6 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28102 exists.

Affected packages and fixed versions:
- jwcrypto (PyPI): affected all versions; fixed in 1.5.6
- jwcrypto (PyPI): affected all versions; fixed in 1.5.6
- jwcrypto (PyPI): affected all versions; fixed in 1.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28102/ (Markdown: https://insights.sbomify.com/CVE-2024-28102/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28102
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28102
- OSV: https://osv.dev/vulnerability/CVE-2024-28102

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28102/
Summaries are generated and may contain mistakes; the official description above is the record.
