CVE-2024-28105 phpMyFAQ's File Upload Bypass at Category Image Leads to RCE
Attackers can upload malicious PHP files via category image upload to achieve remote code execution on phpMyFAQ installations.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-28105?
CVE-2024-28105 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. The category image upload function in phpmyfaq is vulnerable to manipulation of the `Content-type` and `lang` parameters, allowing attackers to upload malicious files with a .php extension, potentially leading to remote code execution (RCE) on the system. This vulnerability is fixed in 3.2.6.
Weakness: CWE-434
Which versions are affected by CVE-2024-28105?
2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyfaq/phpmyfaq Packagist | From 3.2.5 | 3.2.6 |
phpmyfaq/phpmyfaq Packagist | From 3.2.5 | 3.2.6 |
Products include Phpmyfaq Phpmyfaq.
How do I fix CVE-2024-28105?
Upgrade phpmyfaq/phpmyfaq to 3.2.6 or later.
Is CVE-2024-28105 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28105 exists.
Other vulnerabilities in Phpmyfaq Phpmyfaq
- CVE-2023-0310 Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq
- CVE-2022-4407 Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq
- CVE-2017-11187 Security feature bypass in n/a
- CVE-2026-76213 phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle
- CVE-2026-76214 phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge
Sources
Also known as GHSA-pwh2-fpfr-x5gf.