CVE-2024-28106 phpMyFAQ Stored XSS at FAQ News Content

Medium 4.3 Published Updated

An attacker can inject malicious JavaScript into FAQ news content, leading to stored XSS when other users view the page.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-28106?

CVE-2024-28106 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. By manipulating the news parameter in a POST request, an attacker can inject malicious JavaScript code. Upon browsing to the compromised news page, the XSS payload triggers. This vulnerability is fixed in 3.2.6.

Weakness: CWE-79

Which versions are affected by CVE-2024-28106?

2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.

PackageAffectedFixed in
phpmyfaq/phpmyfaq PackagistFrom 3.2.53.2.6
phpmyfaq/phpmyfaq PackagistFrom 3.2.53.2.6

Products include Phpmyfaq Phpmyfaq.

How do I fix CVE-2024-28106?

Upgrade phpmyfaq/phpmyfaq to 3.2.6 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-28106 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28106 exists.

All Phpmyfaq Phpmyfaq vulnerabilities

Sources

Also known as GHSA-6p68-36m6-392r.

Is CVE-2024-28106 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free