CVE-2024-28107 phpMyFAQ SQL injections at insertentry & saveentry

High 8.8 Published Updated

Authenticated users can exploit SQL injection in phpMyFAQ to exfiltrate data, take over accounts, or achieve remote code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-28107?

CVE-2024-28107 is a high-severity SQL injection vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. A SQL injection vulnerability has been discovered in the `insertentry` & `saveentry` when modifying records due to improper escaping of the email address. This allows any authenticated user with the rights to add/edit FAQ news to exploit this vulnerability to exfiltrate data, take over accounts and in some cases, even achieve RCE. This vulnerability is fixed in 3.2.6.

Weakness: CWE-89

Which versions are affected by CVE-2024-28107?

2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.

PackageAffectedFixed in
phpmyfaq/phpmyfaq PackagistFrom 3.2.53.2.6
phpmyfaq/phpmyfaq PackagistFrom 3.2.53.2.6

Products include Phpmyfaq Phpmyfaq.

How do I fix CVE-2024-28107?

Upgrade phpmyfaq/phpmyfaq to 3.2.6 or later.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2024-28107 being exploited?

There is no known exploitation of CVE-2024-28107 in the wild and no public exploit code.

All Phpmyfaq Phpmyfaq vulnerabilities

Sources

Also known as GHSA-2grw-mc9r-822r.

Is CVE-2024-28107 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free