{"answers":{"affected":"2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-28107 in the wild and no public exploit code.","fix":"Upgrade phpmyfaq/phpmyfaq to 3.2.6 or later.","what":"CVE-2024-28107 is a high-severity SQL injection vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28107 and fix it if it is affected.\n\nWhat it is: CVE-2024-28107 is a high-severity SQL injection vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-28107 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.5; fixed in 3.2.6\n- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.5; fixed in 3.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28107/ (Markdown: https://insights.sbomify.com/CVE-2024-28107/index.md)","id":"CVE-2024-28107","markdown":"https://insights.sbomify.com/CVE-2024-28107/index.md","name":"CVE-2024-28107","record":{"aliases":["GHSA-2grw-mc9r-822r"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","account_takeover","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ","requires_auth":"low_privilege","summary":"Authenticated users can exploit SQL injection in phpMyFAQ to exfiltrate data, take over accounts, or achieve remote code execution.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases.  A SQL injection vulnerability has been discovered in the `insertentry` \u0026 `saveentry` when modifying records due to improper escaping of the email address. This allows any authenticated user with the rights to add/edit FAQ news to exploit this vulnerability to exfiltrate data, take over accounts and in some cases, even achieve RCE. This vulnerability is fixed in 3.2.6.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyFAQ SQL injections at insertentry \u0026 saveentry","id":"CVE-2024-28107","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":"sql_injection","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"phpMyFAQ Stored HTML Injection at contentLink","id":"CVE-2024-28108"},"packages":[{"ecosystem":"Packagist","fixed":["3.2.6"],"introduced":["3.2.5"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-2grw-mc9r-822r"},{"ecosystem":"Packagist","fixed":["3.2.6"],"introduced":["3.2.5"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-2grw-mc9r-822r"}],"prev":{"headline":"phpMyFAQ Stored XSS at FAQ News Content","id":"CVE-2024-28106"},"products":["phpMyFAQ"],"published":"2024-03-25","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-10","vendors":["thorsten"]},"summary":"Authenticated users can exploit SQL injection in phpMyFAQ to exfiltrate data, take over accounts, or achieve remote code execution.","url":"https://insights.sbomify.com/CVE-2024-28107/"}