CVE-2024-28108 phpMyFAQ Stored HTML Injection at contentLink
Unauthenticated attackers can inject HTML via the contentLink parameter if guest FAQ submission is enabled, potentially affecting other users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-28108?
CVE-2024-28108 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Due to insufficient validation on the `contentLink` parameter, it is possible for unauthenticated users to inject HTML code to the page which might affect other users. _Also, requires that adding new FAQs is allowed for guests and that the admin doesn't check the content of a newly added FAQ._ This vulnerability is fixed in 3.2.6.
Which versions are affected by CVE-2024-28108?
2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyfaq/phpmyfaq Packagist | From 3.2.5 | 3.2.6 |
phpmyfaq/phpmyfaq Packagist | From 3.2.5 | 3.2.6 |
Products include Phpmyfaq Phpmyfaq.
How do I fix CVE-2024-28108?
Upgrade phpmyfaq/phpmyfaq to 3.2.6 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-28108 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28108 exists.
Other vulnerabilities in Phpmyfaq Phpmyfaq
- CVE-2023-0310 Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq
- CVE-2022-4407 Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq
- CVE-2017-11187 Security feature bypass in n/a
- CVE-2026-76213 phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle
- CVE-2026-76214 phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge
Sources
Also known as GHSA-48vw-jpf8-hwqh.