# CVE-2024-28110: Go SDK for CloudEvents's use of WithRoundTripper to create a Client leaks credentials


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 16 Apr 2025
- **Also known as:** AZL-35751, AZL-35761, CLEANSTART-2025-EV96461, GHSA-5pf6-2qwx-pxm2, GO-2024-2618

## What is CVE-2024-28110?

CVE-2024-28110 is a high-severity vulnerability in cloudevents sdk-go, published on 6 Mar 2024. 

### Official description

Go SDK for CloudEvents is the official CloudEvents SDK to integrate applications with CloudEvents. Prior to version 2.15.2, using cloudevents.WithRoundTripper to create a cloudevents.Client with an authenticated http.RoundTripper causes the go-sdk to leak credentials to arbitrary endpoints. When the transport is populated with an authenticated transport, then http.DefaultClient is modified with the authenticated transport and will start to send Authorization tokens to any endpoint it is used to contact. Version 2.15.2 patches this issue.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2024-28110?

3 open source packages ship an affected version, including github.com/cloudevents/sdk-go/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudevents/sdk-go/v2` | Go | All versions | 2.15.2 |
| `github.com/cloudevents/sdk-go/v2` | Go | All versions | 2.15.2 |
| `github.com/cloudevents/sdk-go/v2` | Go | All versions | 2.15.2 |

Products: Cloudevents Go Sdk.

## How do I fix CVE-2024-28110?

Upgrade github.com/cloudevents/sdk-go/v2 to 2.15.2 or later.

## Is CVE-2024-28110 being exploited?

There is no known exploitation of CVE-2024-28110 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28110 and fix it if it is affected.

What it is: CVE-2024-28110 is a high-severity vulnerability in cloudevents sdk-go, published on 6 Mar 2024. 
Exploitation: There is no known exploitation of CVE-2024-28110 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cloudevents/sdk-go/v2 (Go): affected all versions; fixed in 2.15.2
- github.com/cloudevents/sdk-go/v2 (Go): affected all versions; fixed in 2.15.2
- github.com/cloudevents/sdk-go/v2 (Go): affected all versions; fixed in 2.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28110/ (Markdown: https://insights.sbomify.com/CVE-2024-28110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28110
- OSV: https://osv.dev/vulnerability/CVE-2024-28110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28110/
Summaries are generated and may contain mistakes; the official description above is the record.
