# CVE-2024-28116: Server-Side Template Injection (SSTI) with Grav CMS security sandbox bypass

> Authenticated users can execute arbitrary code on the server by bypassing the security sandbox via Server-Side Template Injection.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-c9gp-64c4-2rrh

## What is CVE-2024-28116?

CVE-2024-28116 is a high-severity code injection vulnerability in Getgrav Grav, published on 21 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav is an open-source, flat-file content management system. Grav CMS prior to version 1.7.45 is vulnerable to a Server-Side Template Injection (SSTI), which allows any authenticated user (editor permissions are sufficient) to execute arbitrary code on the remote server bypassing the existing security sandbox. Version 1.7.45 contains a patch for this issue.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2024-28116?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.7.45 |
| `getgrav/grav` | Packagist | All versions | 1.7.45 |

Products: Getgrav Grav.

## How do I fix CVE-2024-28116?

Upgrade getgrav/grav to 1.7.45 or later.

## Is CVE-2024-28116 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28116 exists.

Public exploit code:

- Proof of Concept script to exploit the authenticated SSTI+RCE in Grav CMS (CVE-2024-28116) (github_poc): https://github.com/akabe1/Graver
- is a PoC Python script that exploits an authenticated Server-Side Template Injection (SSTI) vulnerability in Grav CMS versions <= 1.7.44 (CVE-2024-28116) (github_poc): https://github.com/geniuszly/GenGravSSTIExploit
- Exploit against Grav CMS (versions below 1.7.45) that allows Remote Code Execution for an authenticated user - CVE-2024-28116 (github_poc): https://github.com/gunzf0x/Grav-CMS-RCE-Authenticated
- Analysis and Docker reproduction of CVE-2024-28116 - SSTI with sandbox bypass in Grav CMS (github_poc): https://github.com/bebarossi/grav-cve-2024-28116

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28116 and fix it if it is affected.

What it is: CVE-2024-28116 is a high-severity code injection vulnerability in Getgrav Grav, published on 21 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28116 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.45
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.45

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28116/ (Markdown: https://insights.sbomify.com/CVE-2024-28116/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28116
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28116
- OSV: https://osv.dev/vulnerability/CVE-2024-28116

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28116/
Summaries are generated and may contain mistakes; the official description above is the record.
