{"answers":{"affected":"2 open source packages ship an affected version, including wasmi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-28123 in the wild and no public exploit code.","fix":"Upgrade wasmi to 0.31.1 or later.","what":"CVE-2024-28123 is a high-severity memory corruption vulnerability in wasmi-labs wasmi, published on 8 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28123 and fix it if it is affected.\n\nWhat it is: CVE-2024-28123 is a high-severity memory corruption vulnerability in wasmi-labs wasmi, published on 8 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-28123 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wasmi (crates.io): affected from 0.15.0; fixed in 0.31.1\n- wasmi (crates.io): affected from 0.15.0; fixed in 0.31.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28123/ (Markdown: https://insights.sbomify.com/CVE-2024-28123/index.md)","id":"CVE-2024-28123","markdown":"https://insights.sbomify.com/CVE-2024-28123/index.md","name":"CVE-2024-28123","record":{"aliases":["GHSA-75jp-vq8x-h4cq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"WebAssembly interpreter","requires_auth":"none","summary":"An out-of-bounds write in the Wasmi WebAssembly interpreter allows attackers to cause memory corruption or crashes when host calls exceed parameter limits.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"wasmi","vendor":"wasmi-labs"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Wasmi is an efficient and lightweight WebAssembly interpreter with a focus on constrained and embedded systems. In the WASMI Interpreter, an Out-of-bounds Buffer Write will arise if the host calls or resumes a Wasm function with more parameters than the default limit (128), as it will surpass the stack value. This doesn’t affect calls from Wasm to Wasm, only from host to Wasm. This vulnerability was patched in version 0.31.1.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Wasmi Out-of-bounds Write for host to Wasm calls with more than 128 Parameters","id":"CVE-2024-28123","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"FitNesse allows execution of arbitrary OS commands","id":"CVE-2024-28125"},"packages":[{"ecosystem":"crates.io","fixed":["0.31.1"],"introduced":["0.15.0"],"last_affected":[],"package":"wasmi","purl":null,"source":"GHSA-75jp-vq8x-h4cq"},{"ecosystem":"crates.io","fixed":["0.31.1"],"introduced":["0.15.0"],"last_affected":[],"package":"wasmi","purl":"pkg:cargo/wasmi","source":"GHSA-75jp-vq8x-h4cq"}],"prev":{"headline":"JWX vulnerable to a denial of service attack using compressed JWE message","id":"CVE-2024-28122"},"products":["wasmi"],"published":"2024-03-08","related":[{"cvss_score":8.4,"headline":"Wasmi's Linear Memory has a Critical Use After Free Vulnerability","id":"CVE-2025-66627","kev_date_added":null,"published":"2025-12-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-05","vendors":["wasmi-labs"]},"summary":"An out-of-bounds write in the Wasmi WebAssembly interpreter allows attackers to cause memory corruption or crashes when host calls exceed parameter limits.","url":"https://insights.sbomify.com/CVE-2024-28123/"}