# CVE-2024-28123: Wasmi Out-of-bounds Write for host to Wasm calls with more than 128 Parameters

> An out-of-bounds write in the Wasmi WebAssembly interpreter allows attackers to cause memory corruption or crashes when host calls exceed parameter limits.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2024
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-75jp-vq8x-h4cq

## What is CVE-2024-28123?

CVE-2024-28123 is a high-severity memory corruption vulnerability in wasmi-labs wasmi, published on 8 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Wasmi is an efficient and lightweight WebAssembly interpreter with a focus on constrained and embedded systems. In the WASMI Interpreter, an Out-of-bounds Buffer Write will arise if the host calls or resumes a Wasm function with more parameters than the default limit (128), as it will surpass the stack value. This doesn’t affect calls from Wasm to Wasm, only from host to Wasm. This vulnerability was patched in version 0.31.1.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2024-28123?

2 open source packages ship an affected version, including wasmi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmi` | crates.io | From 0.15.0 | 0.31.1 |
| `wasmi` | crates.io | From 0.15.0 | 0.31.1 |

Products: Wasmi-Labs Wasmi.

## How do I fix CVE-2024-28123?

Upgrade wasmi to 0.31.1 or later.

## Is CVE-2024-28123 being exploited?

There is no known exploitation of CVE-2024-28123 in the wild and no public exploit code.

## Other vulnerabilities in wasmi-labs wasmi

- [CVE-2025-66627](https://insights.sbomify.com/CVE-2025-66627/): Wasmi's Linear Memory has a Critical Use After Free Vulnerability (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28123 and fix it if it is affected.

What it is: CVE-2024-28123 is a high-severity memory corruption vulnerability in wasmi-labs wasmi, published on 8 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28123 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmi (crates.io): affected from 0.15.0; fixed in 0.31.1
- wasmi (crates.io): affected from 0.15.0; fixed in 0.31.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28123/ (Markdown: https://insights.sbomify.com/CVE-2024-28123/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28123
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28123
- OSV: https://osv.dev/vulnerability/CVE-2024-28123

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28123/
Summaries are generated and may contain mistakes; the official description above is the record.
