CVE-2024-28148 Apache Superset: Incorrect datasource authorization on explore REST API

Medium 4.3 Published Updated

Authenticated attackers can access unauthorized datasource metadata via the explore REST API in Apache Superset.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-28148?

CVE-2024-28148 is a medium-severity missing authorization vulnerability in Apache Superset, published on 7 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request.This issue affects Apache Superset: before 3.1.2.

Users are recommended to upgrade to version 3.1.2 or above, which fixes the issue.

Weakness: CWE-863

Which versions are affected by CVE-2024-28148?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versions3.1.2
apache-superset PyPIAll versions3.1.2
apache-superset PyPIAll versions3.1.2
superset BitnamiAll versions4.1.1

Products include Apache Superset.

How do I fix CVE-2024-28148?

Upgrade apache-superset to 3.1.2 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-28148 being exploited?

There is no known exploitation of CVE-2024-28148 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2024-28148, GHSA-299q-3p96-5898, PYSEC-2026-1153.

Is CVE-2024-28148 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free