{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:htmlpublisher. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-28149 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:htmlpublisher to 1.32.1 or later.","what":"CVE-2024-28149 is a medium-severity cross-site scripting vulnerability in Jenkins HTML Publisher Plugin, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28149 and fix it if it is affected.\n\nWhat it is: CVE-2024-28149 is a medium-severity cross-site scripting vulnerability in Jenkins HTML Publisher Plugin, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-28149 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:htmlpublisher (Maven): affected from 1.16; fixed in 1.32.1\n- org.jenkins-ci.plugins:htmlpublisher (Maven): affected from 1.16; fixed in 1.32.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28149/ (Markdown: https://insights.sbomify.com/CVE-2024-28149/index.md)","id":"CVE-2024-28149","markdown":"https://insights.sbomify.com/CVE-2024-28149/index.md","name":"CVE-2024-28149","record":{"aliases":["GHSA-8vcg-v7g4-3vr7"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins HTML Publisher Plugin","requires_auth":"none","summary":"Attackers with configure permissions can execute XSS and detect file paths in Jenkins HTML Publisher Plugin.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"html_publisher","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins HTML Publisher Plugin 1.16 through 1.32 (both inclusive) does not properly sanitize input, allowing attackers with Item/Configure permission to implement cross-site scripting (XSS) attacks and to determine whether a path on the Jenkins controller file system exists.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins HTML Publisher Plugin does not properly sanitize input","id":"CVE-2024-28149","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins HTML Publisher Plugin Stored XSS vulnerability","id":"CVE-2024-28150"},"packages":[{"ecosystem":"Maven","fixed":["1.32.1"],"introduced":["1.16"],"last_affected":[],"package":"org.jenkins-ci.plugins:htmlpublisher","purl":null,"source":"GHSA-8vcg-v7g4-3vr7"},{"ecosystem":"Maven","fixed":["1.32.1"],"introduced":["1.16"],"last_affected":[],"package":"org.jenkins-ci.plugins:htmlpublisher","purl":"pkg:maven/org.jenkins-ci.plugins/htmlpublisher","source":"GHSA-8vcg-v7g4-3vr7"}],"prev":{"headline":"Apache Superset: Incorrect datasource authorization on explore REST API","id":"CVE-2024-28148"},"products":["Jenkins HTML Publisher Plugin"],"published":"2024-03-06","related":[{"cvss_score":8,"headline":"Jenkins HTML Publisher Plugin has a XSS vulnerability in the legacy wrapper file","id":"CVE-2026-42524","kev_date_added":null,"published":"2026-04-29"},{"cvss_score":6.5,"headline":"Jenkins HTML Publisher Plugin path traversal vulnerability","id":"CVE-2018-1000175","kev_date_added":null,"published":"2018-05-08"},{"cvss_score":6.3,"headline":"Jenkins HTML Publisher Plugin vulnerability displays controller file system information in its logs","id":"CVE-2025-53651","kev_date_added":null,"published":"2025-07-09"},{"cvss_score":5.4,"headline":"Jenkins HTML Publisher Plugin vulnerable to Cross-site Scripting","id":"CVE-2019-10432","kev_date_added":null,"published":"2019-10-01"},{"cvss_score":4.7,"headline":"Jenkins HTML Publisher Plugin Stored XSS vulnerability","id":"CVE-2024-28150","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":4.3,"headline":"Jenkins HTML Publisher Plugin Path traversal vulnerability","id":"CVE-2024-28151","kev_date_added":null,"published":"2024-03-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Jenkins Project"]},"summary":"Attackers with configure permissions can execute XSS and detect file paths in Jenkins HTML Publisher Plugin.","url":"https://insights.sbomify.com/CVE-2024-28149/"}