# CVE-2024-28149: Jenkins HTML Publisher Plugin does not properly sanitize input

> Attackers with configure permissions can execute XSS and detect file paths in Jenkins HTML Publisher Plugin.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-8vcg-v7g4-3vr7

## What is CVE-2024-28149?

CVE-2024-28149 is a medium-severity cross-site scripting vulnerability in Jenkins HTML Publisher Plugin, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins HTML Publisher Plugin 1.16 through 1.32 (both inclusive) does not properly sanitize input, allowing attackers with Item/Configure permission to implement cross-site scripting (XSS) attacks and to determine whether a path on the Jenkins controller file system exists.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-28149?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:htmlpublisher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:htmlpublisher` | Maven | From 1.16 | 1.32.1 |
| `org.jenkins-ci.plugins:htmlpublisher` | Maven | From 1.16 | 1.32.1 |

Products: Jenkins Html Publisher.

## How do I fix CVE-2024-28149?

Upgrade org.jenkins-ci.plugins:htmlpublisher to 1.32.1 or later.

## Is CVE-2024-28149 being exploited?

There is no known exploitation of CVE-2024-28149 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins HTML Publisher Plugin

- [CVE-2026-42524](https://insights.sbomify.com/CVE-2026-42524/): Jenkins HTML Publisher Plugin has a XSS vulnerability in the legacy wrapper file (high 8.0)
- [CVE-2018-1000175](https://insights.sbomify.com/CVE-2018-1000175/): Jenkins HTML Publisher Plugin path traversal vulnerability (medium 6.5)
- [CVE-2025-53651](https://insights.sbomify.com/CVE-2025-53651/): Jenkins HTML Publisher Plugin vulnerability displays controller file system information in its logs (medium 6.3)
- [CVE-2019-10432](https://insights.sbomify.com/CVE-2019-10432/): Jenkins HTML Publisher Plugin vulnerable to Cross-site Scripting (medium 5.4)
- [CVE-2024-28150](https://insights.sbomify.com/CVE-2024-28150/): Jenkins HTML Publisher Plugin Stored XSS vulnerability (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28149 and fix it if it is affected.

What it is: CVE-2024-28149 is a medium-severity cross-site scripting vulnerability in Jenkins HTML Publisher Plugin, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28149 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:htmlpublisher (Maven): affected from 1.16; fixed in 1.32.1
- org.jenkins-ci.plugins:htmlpublisher (Maven): affected from 1.16; fixed in 1.32.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28149/ (Markdown: https://insights.sbomify.com/CVE-2024-28149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28149
- OSV: https://osv.dev/vulnerability/CVE-2024-28149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28149/
Summaries are generated and may contain mistakes; the official description above is the record.
