{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:dependency-check-jenkins-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-28153 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:dependency-check-jenkins-plugin to 5.4.6 or later.","what":"CVE-2024-28153 is a high-severity cross-site scripting vulnerability in Jenkins OWASP Dependency-Check Plugin, published on 6 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-28153 and fix it if it is affected.\n\nWhat it is: CVE-2024-28153 is a high-severity cross-site scripting vulnerability in Jenkins OWASP Dependency-Check Plugin, published on 6 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-28153 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:dependency-check-jenkins-plugin (Maven): affected all versions; fixed in 5.4.6\n- org.jenkins-ci.plugins:dependency-check-jenkins-plugin (Maven): affected all versions; fixed in 5.4.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28153/ (Markdown: https://insights.sbomify.com/CVE-2024-28153/index.md)","id":"CVE-2024-28153","markdown":"https://insights.sbomify.com/CVE-2024-28153/index.md","name":"CVE-2024-28153","record":{"aliases":["GHSA-9pp4-mx6x-xh36"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins OWASP Dependency-Check Plugin allows attackers to execute scripts via unescaped vulnerability metadata.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"owasp_dependency-check","vendor":"jenkins"}],"cvss":{"score":7.3,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins OWASP Dependency-Check Plugin 5.4.5 and earlier does not escape vulnerability metadata from Dependency-Check reports, resulting in a stored cross-site scripting (XSS) vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins OWASP Dependency-Check Plugin has stored XSS vulnerability","id":"CVE-2024-28153","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins MQ Notifier Plugin exposes sensitive information in build logs","id":"CVE-2024-28154"},"packages":[{"ecosystem":"Maven","fixed":["5.4.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:dependency-check-jenkins-plugin","purl":null,"source":"GHSA-9pp4-mx6x-xh36"},{"ecosystem":"Maven","fixed":["5.4.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:dependency-check-jenkins-plugin","purl":"pkg:maven/org.jenkins-ci.plugins/dependency-check-jenkins-plugin","source":"GHSA-9pp4-mx6x-xh36"}],"prev":{"headline":"Jenkins Bitbucket Branch Source Plugin has incorrect trust policy behavior for pull requests","id":"CVE-2024-28152"},"products":["Jenkins OWASP Dependency-Check Plugin"],"published":"2024-03-06","related":[{"cvss_score":7.1,"headline":"XXE vulnerability in Jenkins OWASP Dependency-Check Plugin","id":"CVE-2021-43577","kev_date_added":null,"published":"2021-11-12"},{"cvss_score":6.1,"headline":"Persistent XSS vulnerability in Jenkins OWASP Dependency-Check Plugin","id":"CVE-2017-1000109","kev_date_added":null,"published":"2017-10-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-25","vendors":["Jenkins Project"]},"summary":"Stored XSS in Jenkins OWASP Dependency-Check Plugin allows attackers to execute scripts via unescaped vulnerability metadata.","url":"https://insights.sbomify.com/CVE-2024-28153/"}