# CVE-2024-28153: Jenkins OWASP Dependency-Check Plugin has stored XSS vulnerability

> Stored XSS in Jenkins OWASP Dependency-Check Plugin allows attackers to execute scripts via unescaped vulnerability metadata.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 25 Mar 2025
- **Also known as:** GHSA-9pp4-mx6x-xh36

## What is CVE-2024-28153?

CVE-2024-28153 is a high-severity cross-site scripting vulnerability in Jenkins OWASP Dependency-Check Plugin, published on 6 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins OWASP Dependency-Check Plugin 5.4.5 and earlier does not escape vulnerability metadata from Dependency-Check reports, resulting in a stored cross-site scripting (XSS) vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-28153?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:dependency-check-jenkins-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:dependency-check-jenkins-plugin` | Maven | All versions | 5.4.6 |
| `org.jenkins-ci.plugins:dependency-check-jenkins-plugin` | Maven | All versions | 5.4.6 |

Products: Jenkins Owasp Dependency-Check.

## How do I fix CVE-2024-28153?

Upgrade org.jenkins-ci.plugins:dependency-check-jenkins-plugin to 5.4.6 or later.

## Is CVE-2024-28153 being exploited?

There is no known exploitation of CVE-2024-28153 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins OWASP Dependency-Check Plugin

- [CVE-2021-43577](https://insights.sbomify.com/CVE-2021-43577/): XXE vulnerability in Jenkins OWASP Dependency-Check Plugin (high 7.1)
- [CVE-2017-1000109](https://insights.sbomify.com/CVE-2017-1000109/): Persistent XSS vulnerability in Jenkins OWASP Dependency-Check Plugin (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28153 and fix it if it is affected.

What it is: CVE-2024-28153 is a high-severity cross-site scripting vulnerability in Jenkins OWASP Dependency-Check Plugin, published on 6 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-28153 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:dependency-check-jenkins-plugin (Maven): affected all versions; fixed in 5.4.6
- org.jenkins-ci.plugins:dependency-check-jenkins-plugin (Maven): affected all versions; fixed in 5.4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28153/ (Markdown: https://insights.sbomify.com/CVE-2024-28153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28153
- OSV: https://osv.dev/vulnerability/CVE-2024-28153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28153/
Summaries are generated and may contain mistakes; the official description above is the record.
