{"answers":{"affected":"2 open source packages ship an affected version, including com.sonymobile.jenkins.plugins.mq:mq-notifier. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-28154 in the wild and no public exploit code.","fix":"Upgrade com.sonymobile.jenkins.plugins.mq:mq-notifier to 1.4.1 or later.","what":"CVE-2024-28154 is a medium-severity vulnerability in Jenkins MQ Notifier Plugin, published on 6 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28154 and fix it if it is affected.\n\nWhat it is: CVE-2024-28154 is a medium-severity vulnerability in Jenkins MQ Notifier Plugin, published on 6 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-28154 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.sonymobile.jenkins.plugins.mq:mq-notifier (Maven): affected all versions; fixed in 1.4.1\n- com.sonymobile.jenkins.plugins.mq:mq-notifier (Maven): affected all versions; fixed in 1.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28154/ (Markdown: https://insights.sbomify.com/CVE-2024-28154/index.md)","id":"CVE-2024-28154","markdown":"https://insights.sbomify.com/CVE-2024-28154/index.md","name":"CVE-2024-28154","record":{"aliases":["GHSA-8fm4-r23p-v68v"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins MQ Notifier Plugin","requires_auth":"low_privilege","summary":"Attackers can read sensitive build parameters from logs because the plugin logs them by default, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"mq_notifier","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"}],"description":"Jenkins MQ Notifier Plugin 1.4.0 and earlier logs potentially sensitive build parameters as part of debug information in build logs by default.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins MQ Notifier Plugin exposes sensitive information in build logs","id":"CVE-2024-28154","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins AppSpider Plugin missing permission checks","id":"CVE-2024-28155"},"packages":[{"ecosystem":"Maven","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"com.sonymobile.jenkins.plugins.mq:mq-notifier","purl":null,"source":"GHSA-8fm4-r23p-v68v"},{"ecosystem":"Maven","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"com.sonymobile.jenkins.plugins.mq:mq-notifier","purl":"pkg:maven/com.sonymobile.jenkins.plugins.mq/mq-notifier","source":"GHSA-8fm4-r23p-v68v"}],"prev":{"headline":"Jenkins OWASP Dependency-Check Plugin has stored XSS vulnerability","id":"CVE-2024-28153"},"products":["Jenkins MQ Notifier Plugin"],"published":"2024-03-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-27","vendors":["Jenkins Project"]},"summary":"Attackers can read sensitive build parameters from logs because the plugin logs them by default, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2024-28154/"}