# CVE-2024-28154: Jenkins MQ Notifier Plugin exposes sensitive information in build logs

> Attackers can read sensitive build parameters from logs because the plugin logs them by default, requiring an upgrade to fix.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 27 Mar 2025
- **Also known as:** GHSA-8fm4-r23p-v68v

## What is CVE-2024-28154?

CVE-2024-28154 is a medium-severity vulnerability in Jenkins MQ Notifier Plugin, published on 6 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins MQ Notifier Plugin 1.4.0 and earlier logs potentially sensitive build parameters as part of debug information in build logs by default.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2024-28154?

2 open source packages ship an affected version, including com.sonymobile.jenkins.plugins.mq:mq-notifier. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.sonymobile.jenkins.plugins.mq:mq-notifier` | Maven | All versions | 1.4.1 |
| `com.sonymobile.jenkins.plugins.mq:mq-notifier` | Maven | All versions | 1.4.1 |

Products: Jenkins Mq Notifier.

## How do I fix CVE-2024-28154?

Upgrade com.sonymobile.jenkins.plugins.mq:mq-notifier to 1.4.1 or later.

## Is CVE-2024-28154 being exploited?

There is no known exploitation of CVE-2024-28154 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28154 and fix it if it is affected.

What it is: CVE-2024-28154 is a medium-severity vulnerability in Jenkins MQ Notifier Plugin, published on 6 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28154 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.sonymobile.jenkins.plugins.mq:mq-notifier (Maven): affected all versions; fixed in 1.4.1
- com.sonymobile.jenkins.plugins.mq:mq-notifier (Maven): affected all versions; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28154/ (Markdown: https://insights.sbomify.com/CVE-2024-28154/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28154
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28154
- OSV: https://osv.dev/vulnerability/CVE-2024-28154

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28154/
Summaries are generated and may contain mistakes; the official description above is the record.
