# CVE-2024-28155: Jenkins AppSpider Plugin missing permission checks

> Attackers with read permissions can access sensitive scan configuration and engine group names due to missing permission checks in the Jenkins AppSpider Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 28 Mar 2025
- **Also known as:** GHSA-xxv9-w5hm-328j

## What is CVE-2024-28155?

CVE-2024-28155 is a medium-severity missing authorization vulnerability in Jenkins AppSpider Plugin, published on 6 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins AppSpider Plugin 1.0.16 and earlier does not perform permission checks in several HTTP endpoints, allowing attackers with Overall/Read permission to obtain information about available scan config names, engine group names, and client names.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-28155?

2 open source packages ship an affected version, including com.rapid7:jenkinsci-appspider-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.rapid7:jenkinsci-appspider-plugin` | Maven | All versions | 1.0.17 |
| `com.rapid7:jenkinsci-appspider-plugin` | Maven | All versions | 1.0.17 |

Products: Jenkins Appspider.

## How do I fix CVE-2024-28155?

Upgrade com.rapid7:jenkinsci-appspider-plugin to 1.0.17 or later.

## Is CVE-2024-28155 being exploited?

There is no known exploitation of CVE-2024-28155 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins AppSpider Plugin

- [CVE-2023-32998](https://insights.sbomify.com/CVE-2023-32998/): Jenkins AppSpider Plugin Cross-Site Request Forgery vulnerability (high 8.8)
- [CVE-2020-2314](https://insights.sbomify.com/CVE-2020-2314/): Password stored in plain text by Jenkins AppSpider Plugin (medium 5.5)
- [CVE-2026-48923](https://insights.sbomify.com/CVE-2026-48923/): Jenkins AppSpider Plugin does not perform a permission check in a method implementing form validation (medium 4.3)
- [CVE-2023-32999](https://insights.sbomify.com/CVE-2023-32999/): Jenkins AppSpider Plugin missing permission check (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28155 and fix it if it is affected.

What it is: CVE-2024-28155 is a medium-severity missing authorization vulnerability in Jenkins AppSpider Plugin, published on 6 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28155 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.rapid7:jenkinsci-appspider-plugin (Maven): affected all versions; fixed in 1.0.17
- com.rapid7:jenkinsci-appspider-plugin (Maven): affected all versions; fixed in 1.0.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28155/ (Markdown: https://insights.sbomify.com/CVE-2024-28155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28155
- OSV: https://osv.dev/vulnerability/CVE-2024-28155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28155/
Summaries are generated and may contain mistakes; the official description above is the record.
