# CVE-2024-28161: Jenkins Delphix Plugin has SSL/TLS certificate validation disabled by default

> The Jenkins Delphix Plugin disables SSL/TLS certificate validation by default, allowing attackers to intercept or manipulate Data Control Tower connections.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-xj36-6xc6-8p9x

## What is CVE-2024-28161?

CVE-2024-28161 is a medium-severity vulnerability in Jenkins Delphix Plugin, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Jenkins Delphix Plugin 3.0.1, a global option for administrators to enable or disable SSL/TLS certificate validation for Data Control Tower (DCT) connections is disabled by default.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2024-28161?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:delphix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:delphix` | Maven | From 3.0.1 | 3.0.2 |
| `org.jenkins-ci.plugins:delphix` | Maven | From 3.0.1 | 3.0.2 |

Products: Jenkins Delphix.

## How do I fix CVE-2024-28161?

Upgrade org.jenkins-ci.plugins:delphix to 3.0.2 or later.

## Is CVE-2024-28161 being exploited?

There is no known exploitation of CVE-2024-28161 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Delphix Plugin

- [CVE-2019-10453](https://insights.sbomify.com/CVE-2019-10453/): Jenkins Delphix Plugin vulnerable to Cleartext credential storage (high 7.8)
- [CVE-2023-40345](https://insights.sbomify.com/CVE-2023-40345/): Jenkins Delphix Plugin vulnerable to exposure of system-scoped credentials (medium 6.5)
- [CVE-2023-40344](https://insights.sbomify.com/CVE-2023-40344/): Jenkins Delphix Plugin missing permission check (medium 4.3)
- [CVE-2024-28162](https://insights.sbomify.com/CVE-2024-28162/): Jenkins Delphix Plugin has improper SSL/TLS certificate validation (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28161 and fix it if it is affected.

What it is: CVE-2024-28161 is a medium-severity vulnerability in Jenkins Delphix Plugin, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28161 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:delphix (Maven): affected from 3.0.1; fixed in 3.0.2
- org.jenkins-ci.plugins:delphix (Maven): affected from 3.0.1; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28161/ (Markdown: https://insights.sbomify.com/CVE-2024-28161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28161
- OSV: https://osv.dev/vulnerability/CVE-2024-28161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28161/
Summaries are generated and may contain mistakes; the official description above is the record.
