# CVE-2024-28175: Cross-site scripting on application summary component in argo-cd

> Attackers can inject malicious scripts via annotations in Argo CD, allowing them to execute code and escalate privileges on behalf of victims.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Mar 2024
- **Updated:** 21 Aug 2024
- **Also known as:** BIT-argo-cd-2024-28175, GHSA-jwv5-8mqv-g387, GO-2024-2646

## What is CVE-2024-28175?

CVE-2024-28175 is a critical cross-site scripting vulnerability in Argoproj Argo Cd, published on 13 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. Due to the improper URL protocols filtering of links specified in the `link.argocd.argoproj.io` annotations in the application summary component, an attacker can achieve cross-site scripting with elevated permissions. All unpatched versions of Argo CD starting with v1.0.0 are vulnerable to a cross-site scripting (XSS) bug allowing a malicious user to inject a javascript: link in the UI. When clicked by a victim user, the script will execute with the victim's permissions (up to and including admin). This vulnerability allows an attacker to perform arbitrary actions on behalf of the victim via the API, such as creating, modifying, and deleting Kubernetes resources. A patch for this vulnerability has been released in Argo CD versions v2.10.3 v2.9.8, and v2.8.12. There are no completely-safe workarounds besides upgrading. The safest alternative, if upgrading is not possible, would be to create a Kubernetes admission controller to reject any resources with an annotation starting with link.argocd.argoproj.io or reject the resource if the value use an improper URL protocol. This validation will need to be applied in all clusters managed by ArgoCD.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-28175?

11 open source packages ship an affected version, including github.com/argoproj/argo-cd/v2, argo-cd and github.com/argoproj/argo-cd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.0.0 | 2.8.12, 2.9.8, 2.10.3 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.0.0 | 2.8.12 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.0.0 | 2.8.12 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.10.0 | 2.10.3 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.10.0 | 2.10.3 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.9.0 | 2.9.8 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.9.0 | 2.9.8 |
| `argo-cd` | Bitnami | From 1.0.0 | 2.10.3 |
| `github.com/argoproj/argo-cd` | Go | From 1.0.0 | None |
| `github.com/argoproj/argo-cd` | Go | From 1.0.0 to 1.8.7 | None |
| `github.com/argoproj/argo-cd` | Go | From 1.0.0 to 1.8.7 | None |

Products: Argoproj Argo Cd.

## How do I fix CVE-2024-28175?

Upgrade github.com/argoproj/argo-cd/v2 to a fixed version for your release line: 2.8.12, 2.9.8 or 2.10.3.

## Is CVE-2024-28175 being exploited?

There is no known exploitation of CVE-2024-28175 in the wild and no public exploit code.

## Other vulnerabilities in Argoproj Argo Cd

- [CVE-2025-55190](https://insights.sbomify.com/CVE-2025-55190/): Argo CD: Project API Token Exposes Repository Credentials (critical 10.0)
- [CVE-2022-29165](https://insights.sbomify.com/CVE-2022-29165/): Argo CD will blindly trust JWT claims if anonymous access is enabled (critical 10.0)
- [CVE-2023-40029](https://insights.sbomify.com/CVE-2023-40029/): Cluster secret might leak in cluster details page in Argo CD (critical 9.9)
- [CVE-2022-24768](https://insights.sbomify.com/CVE-2022-24768/): Improper access control allows admin privilege escalation in Argo CD (critical 9.9)
- [CVE-2024-21652](https://insights.sbomify.com/CVE-2024-21652/): Argo CD vulnerable to Bypassing of Brute Force Protection via Application Crash and In-Memory Data Loss (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28175 and fix it if it is affected.

What it is: CVE-2024-28175 is a critical cross-site scripting vulnerability in Argoproj Argo Cd, published on 13 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-28175 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.0.0; fixed in 2.8.12, 2.9.8, 2.10.3
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.0.0; fixed in 2.8.12
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.0.0; fixed in 2.8.12
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.10.0; fixed in 2.10.3
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.10.0; fixed in 2.10.3
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.9.0; fixed in 2.9.8
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.9.0; fixed in 2.9.8
- argo-cd (Bitnami): affected from 1.0.0; fixed in 2.10.3
- github.com/argoproj/argo-cd (Go): affected from 1.0.0; no fix listed
- github.com/argoproj/argo-cd (Go): affected from 1.0.0 up to 1.8.7; no fix listed
- github.com/argoproj/argo-cd (Go): affected from 1.0.0 up to 1.8.7; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28175/ (Markdown: https://insights.sbomify.com/CVE-2024-28175/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28175
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28175
- OSV: https://osv.dev/vulnerability/CVE-2024-28175

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28175/
Summaries are generated and may contain mistakes; the official description above is the record.
