{"answers":{"affected":"5 open source packages ship an affected version, including jupyter-server-proxy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-28179 in the wild and no public exploit code.","fix":"Upgrade jupyter-server-proxy to a fixed version for your release line: 3.2.3 or 4.1.1.","what":"CVE-2024-28179 is a critical missing authorization vulnerability in jupyterhub jupyter-server-proxy, published on 20 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28179 and fix it if it is affected.\n\nWhat it is: CVE-2024-28179 is a critical missing authorization vulnerability in jupyterhub jupyter-server-proxy, published on 20 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-28179 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jupyter-server-proxy (PyPI): affected all versions; fixed in 3.2.3, 4.1.1\n- jupyter-server-proxy (PyPI): affected all versions; fixed in 3.2.3\n- jupyter-server-proxy (PyPI): affected all versions; fixed in 3.2.3\n- jupyter-server-proxy (PyPI): affected from 4.0.0; fixed in 4.1.1\n- jupyter-server-proxy (PyPI): affected from 4.0.0; fixed in 4.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28179/ (Markdown: https://insights.sbomify.com/CVE-2024-28179/index.md)","id":"CVE-2024-28179","markdown":"https://insights.sbomify.com/CVE-2024-28179/index.md","name":"CVE-2024-28179","record":{"aliases":["GHSA-w3vc-fx9p-wp4v","PYSEC-2024-234"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jupyter server proxy","requires_auth":"none","summary":"Unauthenticated attackers can access websocket endpoints in Jupyter Server Proxy, potentially leading to remote arbitrary code execution.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jupyter_server_proxy","vendor":"jupyter"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"Jupyter Server Proxy allows users to run arbitrary external processes alongside their Jupyter notebook servers and provides authenticated web access. Prior to versions 3.2.3 and 4.1.1, Jupyter Server Proxy did not check user authentication appropriately when proxying websockets, allowing unauthenticated access to anyone who had network access to the Jupyter server endpoint. This vulnerability can allow unauthenticated remote access to any websocket endpoint set up to be accessible via Jupyter Server Proxy. In many cases, this leads to remote unauthenticated arbitrary code execution, due to how affected instances use websockets. The websocket endpoints exposed by `jupyter_server` itself is not affected. Projects that do not rely on websockets are also not affected. Versions 3.2.3 and 4.1.1 contain a fix for this issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jupyter Server Proxy's Websocket Proxying does not require authentication","id":"CVE-2024-28179","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":5,"n_references":4,"next":{"headline":"Go JOSE vulnerable to Improper Handling of Highly Compressed Data (Data Amplification)","id":"CVE-2024-28180"},"packages":[{"ecosystem":"PyPI","fixed":["3.2.3","4.1.1"],"introduced":["0","4.0.0"],"last_affected":[],"package":"jupyter-server-proxy","purl":"pkg:pypi/jupyter-server-proxy","source":"PYSEC-2024-234"},{"ecosystem":"PyPI","fixed":["3.2.3"],"introduced":["0"],"last_affected":[],"package":"jupyter-server-proxy","purl":null,"source":"GHSA-w3vc-fx9p-wp4v"},{"ecosystem":"PyPI","fixed":["3.2.3"],"introduced":["0"],"last_affected":[],"package":"jupyter-server-proxy","purl":"pkg:pypi/jupyter-server-proxy","source":"GHSA-w3vc-fx9p-wp4v"},{"ecosystem":"PyPI","fixed":["4.1.1"],"introduced":["4.0.0"],"last_affected":[],"package":"jupyter-server-proxy","purl":null,"source":"GHSA-w3vc-fx9p-wp4v"},{"ecosystem":"PyPI","fixed":["4.1.1"],"introduced":["4.0.0"],"last_affected":[],"package":"jupyter-server-proxy","purl":"pkg:pypi/jupyter-server-proxy","source":"GHSA-w3vc-fx9p-wp4v"}],"prev":{"headline":"jose vulnerable to resource exhaustion via specifically crafted JWE with compressed plaintext","id":"CVE-2024-28176"},"products":["jupyter-server-proxy"],"published":"2024-03-20","related":[{"cvss_score":9.7,"headline":"Jupyter Server Proxy has a reflected XSS issue in host parameter","id":"CVE-2024-35225","kev_date_added":null,"published":"2024-06-11"},{"cvss_score":6.3,"headline":"SSRF vulnerability (requires authentication)","id":"CVE-2022-21697","kev_date_added":null,"published":"2022-01-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["jupyterhub"]},"summary":"Unauthenticated attackers can access websocket endpoints in Jupyter Server Proxy, potentially leading to remote arbitrary code execution.","url":"https://insights.sbomify.com/CVE-2024-28179/"}