# CVE-2024-28179: Jupyter Server Proxy's Websocket Proxying does not require authentication

> Unauthenticated attackers can access websocket endpoints in Jupyter Server Proxy, potentially leading to remote arbitrary code execution.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-w3vc-fx9p-wp4v, PYSEC-2024-234

## What is CVE-2024-28179?

CVE-2024-28179 is a critical missing authorization vulnerability in jupyterhub jupyter-server-proxy, published on 20 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jupyter Server Proxy allows users to run arbitrary external processes alongside their Jupyter notebook servers and provides authenticated web access. Prior to versions 3.2.3 and 4.1.1, Jupyter Server Proxy did not check user authentication appropriately when proxying websockets, allowing unauthenticated access to anyone who had network access to the Jupyter server endpoint. This vulnerability can allow unauthenticated remote access to any websocket endpoint set up to be accessible via Jupyter Server Proxy. In many cases, this leads to remote unauthenticated arbitrary code execution, due to how affected instances use websockets. The websocket endpoints exposed by `jupyter_server` itself is not affected. Projects that do not rely on websockets are also not affected. Versions 3.2.3 and 4.1.1 contain a fix for this issue.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2024-28179?

5 open source packages ship an affected version, including jupyter-server-proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-server-proxy` | PyPI | All versions | 3.2.3, 4.1.1 |
| `jupyter-server-proxy` | PyPI | All versions | 3.2.3 |
| `jupyter-server-proxy` | PyPI | All versions | 3.2.3 |
| `jupyter-server-proxy` | PyPI | From 4.0.0 | 4.1.1 |
| `jupyter-server-proxy` | PyPI | From 4.0.0 | 4.1.1 |

Products: Jupyter Jupyter Server Proxy.

## How do I fix CVE-2024-28179?

Upgrade jupyter-server-proxy to a fixed version for your release line: 3.2.3 or 4.1.1.

## Is CVE-2024-28179 being exploited?

There is no known exploitation of CVE-2024-28179 in the wild and no public exploit code.

## Other vulnerabilities in jupyterhub jupyter-server-proxy

- [CVE-2024-35225](https://insights.sbomify.com/CVE-2024-35225/): Jupyter Server Proxy has a reflected XSS issue in host parameter (critical 9.7)
- [CVE-2022-21697](https://insights.sbomify.com/CVE-2022-21697/): SSRF vulnerability (requires authentication) (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28179 and fix it if it is affected.

What it is: CVE-2024-28179 is a critical missing authorization vulnerability in jupyterhub jupyter-server-proxy, published on 20 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28179 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-server-proxy (PyPI): affected all versions; fixed in 3.2.3, 4.1.1
- jupyter-server-proxy (PyPI): affected all versions; fixed in 3.2.3
- jupyter-server-proxy (PyPI): affected all versions; fixed in 3.2.3
- jupyter-server-proxy (PyPI): affected from 4.0.0; fixed in 4.1.1
- jupyter-server-proxy (PyPI): affected from 4.0.0; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28179/ (Markdown: https://insights.sbomify.com/CVE-2024-28179/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28179
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28179
- OSV: https://osv.dev/vulnerability/CVE-2024-28179

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28179/
Summaries are generated and may contain mistakes; the official description above is the record.
