CVE-2024-2818 Allocation of Resources Without Limits or Throttling in GitLab

Medium 4.3 Published Updated

An attacker can cause a denial of service in GitLab by submitting maliciously crafted label descriptions, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-2818?

CVE-2024-2818 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 28 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 16.8.5, all versions starting from 16.9 before 16.9.3, all versions starting from 16.10 before 16.10.1. It was possible for an attacker to cause a denial of service using malicious crafted description parameter for labels.

Weakness: CWE-770

Which versions are affected by CVE-2024-2818?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions16.8.5, 16.9.3, 16.10.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-2818?

Upgrade gitlab to a fixed version for your release line: 16.8.5, 16.9.3 or 16.10.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-2818 being exploited?

There is no known exploitation of CVE-2024-2818 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-2818, GHSA-2r57-8pgj-h27p, UBUNTU-CVE-2024-2818.

Is CVE-2024-2818 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free