# CVE-2024-2818: Allocation of Resources Without Limits or Throttling in GitLab

> An attacker can cause a denial of service in GitLab by submitting maliciously crafted label descriptions, requiring an upgrade to patched versions.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2024
- **Updated:** 3 Oct 2024
- **Also known as:** BIT-gitlab-2024-2818, GHSA-2r57-8pgj-h27p, UBUNTU-CVE-2024-2818

## What is CVE-2024-2818?

CVE-2024-2818 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 28 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 16.8.5, all versions starting from 16.9 before 16.9.3, all versions starting from 16.10 before 16.10.1. It was possible for an attacker to cause a denial of service using malicious crafted description parameter for labels.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-2818?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | All versions | 16.8.5, 16.9.3, 16.10.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2024-2818?

Upgrade gitlab to a fixed version for your release line: 16.8.5, 16.9.3 or 16.10.1.

## Is CVE-2024-2818 being exploited?

There is no known exploitation of CVE-2024-2818 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2818 and fix it if it is affected.

What it is: CVE-2024-2818 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 28 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-2818 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected all versions; fixed in 16.8.5, 16.9.3, 16.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2818/ (Markdown: https://insights.sbomify.com/CVE-2024-2818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2818
- OSV: https://osv.dev/vulnerability/CVE-2024-2818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2818/
Summaries are generated and may contain mistakes; the official description above is the record.
