# CVE-2024-28184: WeasyPrint allows the attachment of arbitrary files and URLs to a PDF

> WeasyPrint allows attackers to attach arbitrary local files or URLs to generated PDFs, bypassing url_fetcher restrictions and exposing sensitive data.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2024
- **Updated:** 13 Feb 2025
- **Also known as:** DEBIAN-CVE-2024-28184, GHSA-35jj-wx47-4w8r, PYSEC-2026-2033, UBUNTU-CVE-2024-28184

## What is CVE-2024-28184?

CVE-2024-28184 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 9 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

WeasyPrint helps web developers to create PDF documents. Since version 61.0, there's a vulnerability which allows attaching content of arbitrary files and URLs to a generated PDF document, even if `url_fetcher` is configured to prevent access to files and URLs. This vulnerability has been patched in version 61.2.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2024-28184?

3 open source packages ship an affected version, including weasyprint. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weasyprint` | PyPI | From 61.0 | 61.2 |
| `weasyprint` | PyPI | From 61.0 | 61.2 |
| `weasyprint` | PyPI | From 61.0 | 61.2 |

Products: Fedoraproject Fedora, Kozea Weasyprint.

## How do I fix CVE-2024-28184?

Upgrade weasyprint to 61.2 or later.

## Is CVE-2024-28184 being exploited?

There is no known exploitation of CVE-2024-28184 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28184 and fix it if it is affected.

What it is: CVE-2024-28184 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 9 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28184 in the wild and no public exploit code.

Affected packages and fixed versions:
- weasyprint (PyPI): affected from 61.0; fixed in 61.2
- weasyprint (PyPI): affected from 61.0; fixed in 61.2
- weasyprint (PyPI): affected from 61.0; fixed in 61.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28184/ (Markdown: https://insights.sbomify.com/CVE-2024-28184/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28184
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28184
- OSV: https://osv.dev/vulnerability/CVE-2024-28184

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28184/
Summaries are generated and may contain mistakes; the official description above is the record.
