CVE-2024-28191 Contao may have unencoded insert tags in the frontend

Low 3.1 Published Updated

Attackers can inject malicious insert tags in frontend forms, potentially leading to code execution or security bypass in Contao CMS.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-28191?

CVE-2024-28191 is a low-severity cross-site scripting vulnerability in contao, published on 9 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, it is possible to inject insert tags in frontend forms if the output is structured in a very specific way. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, do not output user data from frontend forms next to each other, always separate them by at least one character.

Weakness: CWE-74

Which versions are affected by CVE-2024-28191?

4 open source packages ship an affected version, including contao/core-bundle. It affects 1 product.

PackageAffectedFixed in
contao/core-bundle PackagistFrom 4.0.04.13.40
contao/core-bundle PackagistFrom 4.0.04.13.40
contao/core-bundle PackagistFrom 5.0.0-RC15.3.4
contao/core-bundle PackagistFrom 5.0.0-RC15.3.4

Products include Contao Contao.

How do I fix CVE-2024-28191?

Upgrade contao/core-bundle to a fixed version for your release line: 4.13.40 or 5.3.4.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-28191 being exploited?

There is no known exploitation of CVE-2024-28191 in the wild and no public exploit code.

Sources

Also known as GHSA-747v-52c4-8vj8.

Is CVE-2024-28191 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free