# CVE-2024-28191: Contao may have unencoded insert tags in the frontend

> Attackers can inject malicious insert tags in frontend forms, potentially leading to code execution or security bypass in Contao CMS.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-747v-52c4-8vj8

## What is CVE-2024-28191?

CVE-2024-28191 is a low-severity cross-site scripting vulnerability in contao, published on 9 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, it is possible to inject insert tags in frontend forms if the output is structured in a very specific way. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, do not output user data from frontend forms next to each other, always separate them by at least one character.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-28191?

4 open source packages ship an affected version, including contao/core-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.13.40 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.13.40 |
| `contao/core-bundle` | Packagist | From 5.0.0-RC1 | 5.3.4 |
| `contao/core-bundle` | Packagist | From 5.0.0-RC1 | 5.3.4 |

Products: Contao Contao.

## How do I fix CVE-2024-28191?

Upgrade contao/core-bundle to a fixed version for your release line: 4.13.40 or 5.3.4.

## Is CVE-2024-28191 being exploited?

There is no known exploitation of CVE-2024-28191 in the wild and no public exploit code.

## Other vulnerabilities in contao

- [CVE-2022-26265](https://insights.sbomify.com/CVE-2022-26265/): Remote Code Execution in Contao Managed Edition (critical 9.8)
- [CVE-2019-11512](https://insights.sbomify.com/CVE-2019-11512/): Contao SQL injection in the file manager (critical 9.8)
- [CVE-2012-4383](https://insights.sbomify.com/CVE-2012-4383/): Contao core SQL Injection Vulnerability (high 8.8)
- [CVE-2019-19745](https://insights.sbomify.com/CVE-2019-19745/): Unrestricted file uploads in Contao (high 8.8)
- [CVE-2024-28235](https://insights.sbomify.com/CVE-2024-28235/): Contao possible cookie sharing with external domains while checking protected pages for broken links (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28191 and fix it if it is affected.

What it is: CVE-2024-28191 is a low-severity cross-site scripting vulnerability in contao, published on 9 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28191 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.13.40
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.13.40
- contao/core-bundle (Packagist): affected from 5.0.0-RC1; fixed in 5.3.4
- contao/core-bundle (Packagist): affected from 5.0.0-RC1; fixed in 5.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28191/ (Markdown: https://insights.sbomify.com/CVE-2024-28191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28191
- OSV: https://osv.dev/vulnerability/CVE-2024-28191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28191/
Summaries are generated and may contain mistakes; the official description above is the record.
