# CVE-2024-28233: XSS in JupyterHub via Self-XSS leveraged by Cookie Tossing

> Attackers can execute XSS via cookie tossing to gain full API access and take over user sessions in specific JupyterHub deployments.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Mar 2024
- **Updated:** 15 Aug 2024
- **Also known as:** BIT-jupyterhub-2024-28233, DEBIAN-CVE-2024-28233, GHSA-7r3h-4ph8-w38g, PYSEC-2026-1480, UBUNTU-CVE-2024-28233

## What is CVE-2024-28233?

CVE-2024-28233 is a high-severity cross-site scripting vulnerability in jupyterhub, published on 27 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

JupyterHub is an open source multi-user server for Jupyter notebooks. By tricking a user into visiting a malicious subdomain, the attacker can achieve an XSS directly affecting the former's session. More precisely, in the context of JupyterHub, this XSS could achieve full access to JupyterHub API and user's single-user server. The affected configurations are single-origin JupyterHub deployments and JupyterHub deployments with user-controlled applications running on subdomains or peer subdomains of either the Hub or a single-user server. This vulnerability is fixed in 4.1.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-565 (Reliance on Cookies without Validation and Integrity Checking), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-28233?

4 open source packages ship an affected version, including jupyterhub. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterhub` | Bitnami | All versions | 4.1.0 |
| `jupyterhub` | PyPI | All versions | 4.1.0 |
| `jupyterhub` | PyPI | All versions | 4.1.0 |
| `jupyterhub` | PyPI | All versions | 4.1.0 |

Products: Jupyter Jupyterhub.

## How do I fix CVE-2024-28233?

Upgrade jupyterhub to 4.1.0 or later.

## Is CVE-2024-28233 being exploited?

There is no known exploitation of CVE-2024-28233 in the wild and no public exploit code.

## Other vulnerabilities in jupyterhub

- [CVE-2024-41942](https://insights.sbomify.com/CVE-2024-41942/): JupyterHub has a privilege escalation vulnerability with the `admin:users` scope (high 7.2)
- [CVE-2019-10255](https://insights.sbomify.com/CVE-2019-10255/): Open Redirect vulnerability in jupyterhub and notebook (medium 6.1)
- [CVE-2026-40864](https://insights.sbomify.com/CVE-2026-40864/): JupyterHub: Cross-origin form POSTs bypass XSRF (medium 5.4)
- [CVE-2026-33709](https://insights.sbomify.com/CVE-2026-33709/): JupyterHub has an Open Redirect Vulnerability (medium 5.1)
- [CVE-2020-36191](https://insights.sbomify.com/CVE-2020-36191/): Cross-Site Request Forgery in JupyterHub (medium 4.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28233 and fix it if it is affected.

What it is: CVE-2024-28233 is a high-severity cross-site scripting vulnerability in jupyterhub, published on 27 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-28233 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyterhub (Bitnami): affected all versions; fixed in 4.1.0
- jupyterhub (PyPI): affected all versions; fixed in 4.1.0
- jupyterhub (PyPI): affected all versions; fixed in 4.1.0
- jupyterhub (PyPI): affected all versions; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28233/ (Markdown: https://insights.sbomify.com/CVE-2024-28233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28233
- OSV: https://osv.dev/vulnerability/CVE-2024-28233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28233/
Summaries are generated and may contain mistakes; the official description above is the record.
