CVE-2024-28234 Contao has insufficient BBCode sanitizer

Medium 4.3 Published Updated

Attackers can inject CSS styles via BBCode in comments, potentially leading to XSS, if BBCode is enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-28234?

CVE-2024-28234 is a medium-severity cross-site scripting vulnerability in contao, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Contao is an open source content management system. Starting in version 2.0.0 and prior to versions 4.13.40 and 5.3.4, it is possible to inject CSS styles via BBCode in comments. Installations are only affected if BBCode is enabled. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, disable BBCode for comments.

Weakness: CWE-74

Which versions are affected by CVE-2024-28234?

4 open source packages ship an affected version, including contao/comments-bundle. It affects 1 product.

PackageAffectedFixed in
contao/comments-bundle PackagistFrom 2.0.04.13.40
contao/comments-bundle PackagistFrom 2.0.04.13.40
contao/comments-bundle PackagistFrom 5.0.0-RC15.3.4
contao/comments-bundle PackagistFrom 5.0.0-RC15.3.4

Products include Contao Contao.

How do I fix CVE-2024-28234?

Upgrade contao/comments-bundle to a fixed version for your release line: 4.13.40 or 5.3.4.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-28234 being exploited?

There is no known exploitation of CVE-2024-28234 in the wild and no public exploit code.

Sources

Also known as GHSA-j55w-hjpj-825g.

Is CVE-2024-28234 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free