# CVE-2024-28239: URL Redirection to Untrusted Site in OAuth2/OpenID in directus

> Attackers can exploit an open redirect in the OAuth2 login flow to phish users into revealing their passwords.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Mar 2024
- **Updated:** 22 Aug 2024
- **Also known as:** GHSA-fr3w-2p22-6w7p

## What is CVE-2024-28239?

CVE-2024-28239 is a medium-severity vulnerability in Monospace Directus, published on 12 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Directus is a real-time API and App dashboard for managing SQL database content. The authentication API has a `redirect` parameter that can be exploited as an open redirect vulnerability as the user tries to log in via the API URL. There's a redirect that is done after successful login via the Auth API GET request to `directus/auth/login/google?redirect=http://malicious-fishing-site.com`. While credentials don't seem to be passed to the attacker site, the user can be phished into clicking a legitimate directus site and be taken to a malicious site made to look like a an error message "Your password needs to be updated" to phish out the current password. Users who login via OAuth2 into Directus may be at risk. This issue has been addressed in version 10.10.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2024-28239?

2 open source packages ship an affected version, including directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `directus` | npm | All versions | 10.10.0 |
| `directus` | npm | All versions | 10.10.0 |

Products: Monospace Directus.

## How do I fix CVE-2024-28239?

Upgrade directus to 10.10.0 or later.

## Is CVE-2024-28239 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28239 exists.

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28239 and fix it if it is affected.

What it is: CVE-2024-28239 is a medium-severity vulnerability in Monospace Directus, published on 12 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28239 exists.

Affected packages and fixed versions:
- directus (npm): affected all versions; fixed in 10.10.0
- directus (npm): affected all versions; fixed in 10.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28239/ (Markdown: https://insights.sbomify.com/CVE-2024-28239/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28239
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28239
- OSV: https://osv.dev/vulnerability/CVE-2024-28239

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28239/
Summaries are generated and may contain mistakes; the official description above is the record.
