{"answers":{"affected":"2 open source packages ship an affected version, including katex. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-28244 in the wild and no public exploit code.","fix":"Upgrade katex to 0.16.10 or later.","what":"CVE-2024-28244 is a medium-severity denial of service vulnerability in KaTeX, published on 25 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28244 and fix it if it is affected.\n\nWhat it is: CVE-2024-28244 is a medium-severity denial of service vulnerability in KaTeX, published on 25 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-28244 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- katex (npm): affected from 0.15.4; fixed in 0.16.10\n- katex (npm): affected from 0.15.4; fixed in 0.16.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28244/ (Markdown: https://insights.sbomify.com/CVE-2024-28244/index.md)","id":"CVE-2024-28244","markdown":"https://insights.sbomify.com/CVE-2024-28244/index.md","name":"CVE-2024-28244","record":{"aliases":["DEBIAN-CVE-2024-28244","GHSA-cvr6-37gx-v8wc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript math library","requires_auth":"low_privilege","summary":"Attackers can bypass KaTeX's maxExpand limit using Unicode sub/superscripts to cause infinite loops and denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"katex","vendor":"katex"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"KaTeX is a JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions could encounter malicious input using `\\def` or `\\newcommand` that causes a near-infinite loop, despite setting `maxExpand` to avoid such loops. KaTeX supports an option named maxExpand which aims to prevent infinitely recursive macros from consuming all available memory and/or triggering a stack overflow error. Unfortunately, support for \"Unicode (sub|super)script characters\" allows an attacker to bypass this limit. Each sub/superscript group instantiated a separate Parser with its own limit on macro executions, without inheriting the current count of macro executions from its parent. This has been corrected in KaTeX v0.16.10.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"KaTeX's maxExpand bypassed by Unicode sub/superscripts","id":"CVE-2024-28244","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"KaTeX's \\includegraphics does not escape filename","id":"CVE-2024-28245"},"packages":[{"ecosystem":"npm","fixed":["0.16.10"],"introduced":["0.15.4"],"last_affected":[],"package":"katex","purl":null,"source":"GHSA-cvr6-37gx-v8wc"},{"ecosystem":"npm","fixed":["0.16.10"],"introduced":["0.15.4"],"last_affected":[],"package":"katex","purl":"pkg:npm/katex","source":"GHSA-cvr6-37gx-v8wc"}],"prev":{"headline":"KaTeX's maxExpand bypassed by \\edef","id":"CVE-2024-28243"},"products":["KaTeX"],"published":"2024-03-25","related":[{"cvss_score":6.5,"headline":"KaTeX's maxExpand bypassed by \\edef","id":"CVE-2024-28243","kev_date_added":null,"published":"2024-03-25"},{"cvss_score":6.3,"headline":"\\htmlData does not validate attribute names in KaTeX","id":"CVE-2025-23207","kev_date_added":null,"published":"2025-01-17"},{"cvss_score":6.3,"headline":"KaTeX's \\includegraphics does not escape filename","id":"CVE-2024-28245","kev_date_added":null,"published":"2024-03-25"},{"cvss_score":5.5,"headline":"KaTeX is missing normalization of the protocol in URLs allows bypassing forbidden protocols","id":"CVE-2024-28246","kev_date_added":null,"published":"2024-03-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["KaTeX"]},"summary":"Attackers can bypass KaTeX's maxExpand limit using Unicode sub/superscripts to cause infinite loops and denial of service.","url":"https://insights.sbomify.com/CVE-2024-28244/"}