# CVE-2024-28244: KaTeX's maxExpand bypassed by Unicode sub/superscripts

> Attackers can bypass KaTeX's maxExpand limit using Unicode sub/superscripts to cause infinite loops and denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** DEBIAN-CVE-2024-28244, GHSA-cvr6-37gx-v8wc

## What is CVE-2024-28244?

CVE-2024-28244 is a medium-severity denial of service vulnerability in KaTeX, published on 25 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

KaTeX is a JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions could encounter malicious input using `\def` or `\newcommand` that causes a near-infinite loop, despite setting `maxExpand` to avoid such loops. KaTeX supports an option named maxExpand which aims to prevent infinitely recursive macros from consuming all available memory and/or triggering a stack overflow error. Unfortunately, support for "Unicode (sub|super)script characters" allows an attacker to bypass this limit. Each sub/superscript group instantiated a separate Parser with its own limit on macro executions, without inheriting the current count of macro executions from its parent. This has been corrected in KaTeX v0.16.10.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2024-28244?

2 open source packages ship an affected version, including katex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `katex` | npm | From 0.15.4 | 0.16.10 |
| `katex` | npm | From 0.15.4 | 0.16.10 |

Products: Katex Katex.

## How do I fix CVE-2024-28244?

Upgrade katex to 0.16.10 or later.

## Is CVE-2024-28244 being exploited?

There is no known exploitation of CVE-2024-28244 in the wild and no public exploit code.

## Other vulnerabilities in KaTeX

- [CVE-2024-28243](https://insights.sbomify.com/CVE-2024-28243/): KaTeX's maxExpand bypassed by \edef (medium 6.5)
- [CVE-2025-23207](https://insights.sbomify.com/CVE-2025-23207/): \htmlData does not validate attribute names in KaTeX (medium 6.3)
- [CVE-2024-28245](https://insights.sbomify.com/CVE-2024-28245/): KaTeX's \includegraphics does not escape filename (medium 6.3)
- [CVE-2024-28246](https://insights.sbomify.com/CVE-2024-28246/): KaTeX is missing normalization of the protocol in URLs allows bypassing forbidden protocols (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28244 and fix it if it is affected.

What it is: CVE-2024-28244 is a medium-severity denial of service vulnerability in KaTeX, published on 25 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28244 in the wild and no public exploit code.

Affected packages and fixed versions:
- katex (npm): affected from 0.15.4; fixed in 0.16.10
- katex (npm): affected from 0.15.4; fixed in 0.16.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28244/ (Markdown: https://insights.sbomify.com/CVE-2024-28244/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28244
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28244
- OSV: https://osv.dev/vulnerability/CVE-2024-28244

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28244/
Summaries are generated and may contain mistakes; the official description above is the record.
