# CVE-2024-28246: KaTeX is missing normalization of the protocol in URLs allows bypassing forbidden protocols

> Attackers can bypass URL protocol restrictions in KaTeX by using uppercase protocols, potentially injecting malicious JavaScript links if a custom trust function is used.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** DEBIAN-CVE-2024-28246, GHSA-3wc5-fcw2-2329, UBUNTU-CVE-2024-28246

## What is CVE-2024-28246?

CVE-2024-28246 is a medium-severity vulnerability in KaTeX, published on 25 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

KaTeX is a JavaScript library for TeX math rendering on the web. Code that uses KaTeX's `trust` option, specifically that provides a function to blacklist certain URL protocols, can be fooled by URLs in malicious inputs that use uppercase characters in the protocol. In particular, this can allow for malicious input to generate `javascript:` links in the output, even if the `trust` function tries to forbid this protocol via `trust: (context) => context.protocol !== 'javascript'`. Upgrade to KaTeX v0.16.10 to remove this vulnerability.

Weakness: CWE-697 (Incorrect Comparison), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2024-28246?

2 open source packages ship an affected version, including katex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `katex` | npm | From 0.11.0 | 0.16.10 |
| `katex` | npm | From 0.11.0 | 0.16.10 |

Products: Katex Katex.

## How do I fix CVE-2024-28246?

Upgrade katex to 0.16.10 or later.

## Is CVE-2024-28246 being exploited?

There is no known exploitation of CVE-2024-28246 in the wild and no public exploit code.

## Other vulnerabilities in KaTeX

- [CVE-2024-28243](https://insights.sbomify.com/CVE-2024-28243/): KaTeX's maxExpand bypassed by \edef (medium 6.5)
- [CVE-2024-28244](https://insights.sbomify.com/CVE-2024-28244/): KaTeX's maxExpand bypassed by Unicode sub/superscripts (medium 6.5)
- [CVE-2025-23207](https://insights.sbomify.com/CVE-2025-23207/): \htmlData does not validate attribute names in KaTeX (medium 6.3)
- [CVE-2024-28245](https://insights.sbomify.com/CVE-2024-28245/): KaTeX's \includegraphics does not escape filename (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28246 and fix it if it is affected.

What it is: CVE-2024-28246 is a medium-severity vulnerability in KaTeX, published on 25 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-28246 in the wild and no public exploit code.

Affected packages and fixed versions:
- katex (npm): affected from 0.11.0; fixed in 0.16.10
- katex (npm): affected from 0.11.0; fixed in 0.16.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28246/ (Markdown: https://insights.sbomify.com/CVE-2024-28246/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28246
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28246
- OSV: https://osv.dev/vulnerability/CVE-2024-28246

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28246/
Summaries are generated and may contain mistakes; the official description above is the record.
