CVE-2024-28248 Cilium intermittent HTTP policy bypass
Attackers can bypass HTTP security policies in Cilium, allowing unauthorized traffic to pass through the network. Administrators should upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-28248?
CVE-2024-28248 is a high-severity vulnerability in cilium, published on 18 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Starting in version 1.13.9 and prior to versions 1.13.13, 1.14.8, and 1.15.2, Cilium's HTTP policies are not consistently applied to all traffic in the scope of the policies, leading to HTTP traffic being incorrectly and intermittently forwarded when it should be dropped. This issue has been patched in Cilium 1.15.2, 1.14.8, and 1.13.13. There are no known workarounds for this issue.
Weakness: CWE-693
Which versions are affected by CVE-2024-28248?
14 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/cilium/cilium Go | From 1.13.9 | 1.13.13, 1.14.8, 1.15.2 |
github.com/cilium/cilium Go | From 1.13.9 | 1.13.13 |
github.com/cilium/cilium Go | From 1.13.9 | 1.13.13 |
github.com/cilium/cilium Go | From 1.14.0 | 1.14.8 |
github.com/cilium/cilium Go | From 1.14.0 | 1.14.8 |
github.com/cilium/cilium Go | From 1.15.0 | 1.15.2 |
8 more packages
github.com/cilium/cilium Go | From 1.15.0 | 1.15.2 |
cilium Bitnami | From 1.13.9 | 1.13.13, 1.14.8, 1.15.2 |
cilium-operator Bitnami | From 1.13.9 | 1.13.13, 1.14.8, 1.15.2 |
cilium-proxy Bitnami | From 1.13.9 | 1.13.13, 1.14.8, 1.15.2 |
hubble Bitnami | From 1.13.9 | 1.13.13, 1.14.8, 1.15.2 |
hubble-relay Bitnami | From 1.13.9 | 1.13.13, 1.14.8, 1.15.2 |
hubble-ui Bitnami | From 1.13.9 | 1.13.13, 1.14.8, 1.15.2 |
hubble-ui-backend Bitnami | From 1.13.9 | 1.13.13, 1.14.8, 1.15.2 |
Products include Cilium Cilium.
How do I fix CVE-2024-28248?
Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.13.13, 1.14.8 or 1.15.2.
Is CVE-2024-28248 being exploited?
There is no known exploitation of CVE-2024-28248 in the wild and no public exploit code.
Other vulnerabilities in cilium
- CVE-2026-49445 Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access
- CVE-2022-29178 Incorrect Default Permissions in Cilium
- CVE-2024-28860 Insecure IPsec transport encryption in Cilium
- CVE-2026-41520 Cillium exposes sensitive information included in the cilium-bugtool debug archive
- CVE-2024-37307 Cilium leaks sensitive information in cilium-bugtool
Sources
Also known as BIT-cilium-2024-28248, BIT-cilium-operator-2024-28248, BIT-cilium-proxy-2024-28248, BIT-hubble-2024-28248, BIT-hubble-relay-2024-28248, BIT-hubble-ui-2024-28248 and 3 more.