# CVE-2024-28249: Cilium has possible unencrypted traffic between nodes when using IPsec and L7 policies

> Attackers can read unencrypted traffic between nodes when IPsec and L7 policies are enabled in Cilium clusters.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-cilium-2024-28249, BIT-cilium-operator-2024-28249, BIT-cilium-proxy-2024-28249, BIT-hubble-2024-28249, BIT-hubble-relay-2024-28249, BIT-hubble-ui-2024-28249, BIT-hubble-ui-backend-2024-28249, GHSA-j89h-qrvr-xc36, GO-2024-2656

## What is CVE-2024-28249?

CVE-2024-28249 is a medium-severity vulnerability in cilium, published on 18 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Prior to versions 1.13.13, 1.14.8, and 1.15.2, in Cilium clusters with IPsec enabled and traffic matching Layer 7 policies, IPsec-eligible traffic between a node's Envoy proxy and pods on other nodes is sent unencrypted and IPsec-eligible traffic between a node's DNS proxy and pods on other nodes is sent unencrypted. This issue has been resolved in Cilium 1.15.2, 1.14.8, and 1.13.13. There is no known workaround for this issue.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information), CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2024-28249?

14 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | All versions | 1.13.13, 1.14.8, 1.15.2 |
| `github.com/cilium/cilium` | Go | All versions | 1.13.13 |
| `github.com/cilium/cilium` | Go | All versions | 1.13.13 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.8 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.8 |
| `github.com/cilium/cilium` | Go | From 1.15.0 | 1.15.2 |
| `github.com/cilium/cilium` | Go | From 1.15.0 | 1.15.2 |
| `cilium` | Bitnami | All versions | 1.13.13, 1.14.8, 1.15.2 |
| `cilium-operator` | Bitnami | All versions | 1.13.13, 1.14.8, 1.15.2 |
| `cilium-proxy` | Bitnami | All versions | 1.13.13, 1.14.8, 1.15.2 |
| `hubble` | Bitnami | All versions | 1.13.13, 1.14.8, 1.15.2 |
| `hubble-relay` | Bitnami | All versions | 1.13.13, 1.14.8, 1.15.2 |
| `hubble-ui` | Bitnami | All versions | 1.13.13, 1.14.8, 1.15.2 |
| `hubble-ui-backend` | Bitnami | All versions | 1.13.13, 1.14.8, 1.15.2 |

Products: Cilium Cilium.

## How do I fix CVE-2024-28249?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.13.13, 1.14.8 or 1.15.2.

## Is CVE-2024-28249 being exploited?

There is no known exploitation of CVE-2024-28249 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28249 and fix it if it is affected.

What it is: CVE-2024-28249 is a medium-severity vulnerability in cilium, published on 18 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28249 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.13.13, 1.14.8, 1.15.2
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.13.13
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.13.13
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.8
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.8
- github.com/cilium/cilium (Go): affected from 1.15.0; fixed in 1.15.2
- github.com/cilium/cilium (Go): affected from 1.15.0; fixed in 1.15.2
- cilium (Bitnami): affected all versions; fixed in 1.13.13, 1.14.8, 1.15.2
- cilium-operator (Bitnami): affected all versions; fixed in 1.13.13, 1.14.8, 1.15.2
- cilium-proxy (Bitnami): affected all versions; fixed in 1.13.13, 1.14.8, 1.15.2
- hubble (Bitnami): affected all versions; fixed in 1.13.13, 1.14.8, 1.15.2
- hubble-relay (Bitnami): affected all versions; fixed in 1.13.13, 1.14.8, 1.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28249/ (Markdown: https://insights.sbomify.com/CVE-2024-28249/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28249
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28249
- OSV: https://osv.dev/vulnerability/CVE-2024-28249

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28249/
Summaries are generated and may contain mistakes; the official description above is the record.
