CVE-2024-28250 Cilium has possible unencrypted traffic between nodes when using WireGuard and L7 policies
Attackers can read unencrypted traffic between nodes when using WireGuard with L7 policies in specific Cilium configurations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-28250?
CVE-2024-28250 is a medium-severity vulnerability in cilium, published on 18 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Starting in version 1.14.0 and prior to versions 1.14.8 and 1.15.2, In Cilium clusters with WireGuard enabled and traffic matching Layer 7 policies Wireguard-eligible traffic that is sent between a node's Envoy proxy and pods on other nodes is sent unencrypted and Wireguard-eligible traffic that is sent between a node's DNS proxy and pods on other nodes is sent unencrypted. This issue has been resolved in Cilium 1.14.8 and 1.15.2 in in native routing mode (`routingMode=native`) and in Cilium 1.14.4 in tunneling mode (`routingMode=tunnel`). Not that in tunneling mode, `encryption.wireguard.encapsulate` must be set to `true`. There is no known workaround for this issue.
Which versions are affected by CVE-2024-28250?
12 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/cilium/cilium Go | From 1.14.0 | 1.14.8, 1.15.2 |
github.com/cilium/cilium Go | From 1.14.0 | 1.14.8 |
github.com/cilium/cilium Go | From 1.14.0 | 1.14.8 |
github.com/cilium/cilium Go | From 1.15.0 | 1.15.2 |
github.com/cilium/cilium Go | From 1.15.0 | 1.15.2 |
cilium Bitnami | From 1.14.0 | 1.14.8, 1.15.2 |
6 more packages
cilium-operator Bitnami | From 1.14.0 | 1.14.8, 1.15.2 |
cilium-proxy Bitnami | From 1.14.0 | 1.14.8, 1.15.2 |
hubble Bitnami | From 1.14.0 | 1.14.8, 1.15.2 |
hubble-relay Bitnami | From 1.14.0 | 1.14.8, 1.15.2 |
hubble-ui Bitnami | From 1.14.0 | 1.14.8, 1.15.2 |
hubble-ui-backend Bitnami | From 1.14.0 | 1.14.8, 1.15.2 |
Products include Cilium Cilium.
How do I fix CVE-2024-28250?
Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.14.8 or 1.15.2.
Is CVE-2024-28250 being exploited?
There is no known exploitation of CVE-2024-28250 in the wild and no public exploit code.
Other vulnerabilities in cilium
- CVE-2026-49445 Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access
- CVE-2022-29178 Incorrect Default Permissions in Cilium
- CVE-2024-28860 Insecure IPsec transport encryption in Cilium
- CVE-2026-41520 Cillium exposes sensitive information included in the cilium-bugtool debug archive
- CVE-2024-37307 Cilium leaks sensitive information in cilium-bugtool
Sources
Also known as BIT-cilium-2024-28250, BIT-cilium-operator-2024-28250, BIT-cilium-proxy-2024-28250, BIT-hubble-2024-28250, BIT-hubble-relay-2024-28250, BIT-hubble-ui-2024-28250 and 3 more.