# CVE-2024-28253: SpEL Injection in `PUT /api/v1/policies` in OpenMetadata

> An attacker can achieve remote code execution by injecting Spring Expression Language payloads into policy creation requests before authorization checks occur.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Mar 2024
- **Updated:** 28 Aug 2024
- **Also known as:** GHSA-7vf4-x5m2-r6gr

## What is CVE-2024-28253?

CVE-2024-28253 is a critical code injection vulnerability in open-metadata OpenMetadata, published on 15 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenMetadata is a unified platform for discovery, observability, and governance powered by a central metadata repository, in-depth lineage, and seamless team collaboration. `CompiledRule::validateExpression` is also called from `PolicyRepository.prepare`. `prepare()` is called from `EntityRepository.prepareInternal()` which, in turn, gets called from `EntityResource.createOrUpdate()`. Note that even though there is an authorization check (`authorizer.authorize()`), it gets called after `prepareInternal()` gets called and therefore after the SpEL expression has been evaluated. In order to reach this method, an attacker can send a PUT request to `/api/v1/policies` which gets handled by `PolicyResource.createOrUpdate()`. This vulnerability was discovered with the help of CodeQL's Expression language injection (Spring) query and is also tracked as `GHSL-2023-252`. This issue may lead to Remote Code Execution and has been addressed in version 1.3.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-28253?

2 open source packages ship an affected version, including org.open-metadata:openmetadata-service. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.open-metadata:openmetadata-service` | Maven | All versions | 1.3.1 |
| `org.open-metadata:openmetadata-service` | Maven | All versions | 1.3.1 |

Products: Open-Metadata Openmetadata.

## How do I fix CVE-2024-28253?

Upgrade org.open-metadata:openmetadata-service to 1.3.1 or later.

## Is CVE-2024-28253 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28253 exists.

Public exploit code:

- OpenMetaData - SpEL Injection in PUT /api/v1/policies (nuclei): http/cves/2024/CVE-2024-28253.yaml

## Other vulnerabilities in open-metadata OpenMetadata

- [CVE-2024-28255](https://insights.sbomify.com/CVE-2024-28255/): Authentication Bypass in OpenMetadata (critical 9.8)
- [CVE-2024-28254](https://insights.sbomify.com/CVE-2024-28254/): SpEL Injection in `GET /api/v1/events/subscriptions/validation/condition/<expr>` in OpenMetadata (high 8.8)
- [CVE-2024-28847](https://insights.sbomify.com/CVE-2024-28847/): SpEL Injection in `PUT /api/v1/events/subscriptions` in OpenMetadata (high 8.8)
- [CVE-2024-28848](https://insights.sbomify.com/CVE-2024-28848/): SpEL Injection in `GET /api/v1/policies/validation/condition/<expr>` in OpenMetadata (high 8.8)
- [CVE-2026-22244](https://insights.sbomify.com/CVE-2026-22244/): OpenMetadata Server-Side Template Injection (SSTI) in FreeMarker email templates that leads to RCE (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28253 and fix it if it is affected.

What it is: CVE-2024-28253 is a critical code injection vulnerability in open-metadata OpenMetadata, published on 15 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28253 exists.

Affected packages and fixed versions:
- org.open-metadata:openmetadata-service (Maven): affected all versions; fixed in 1.3.1
- org.open-metadata:openmetadata-service (Maven): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28253/ (Markdown: https://insights.sbomify.com/CVE-2024-28253/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28253
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28253
- OSV: https://osv.dev/vulnerability/CVE-2024-28253

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28253/
Summaries are generated and may contain mistakes; the official description above is the record.
