CVE-2024-2829 Inefficient Regular Expression Complexity in GitLab

High 7.5 Published Updated

Attackers can cause denial of service in GitLab by submitting crafted wildcard filters that trigger inefficient regular expression processing.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-2829?

CVE-2024-2829 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 25 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.5 before 16.9.6, all versions starting from 16.10 before 16.10.4, all versions starting from 16.11 before 16.11.1. A crafted wildcard filter in FileFinder may lead to a denial of service.

Weakness: CWE-1333

Which versions are affected by CVE-2024-2829?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.5.016.9.6, 16.10.4, 16.11.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-2829?

Upgrade gitlab to a fixed version for your release line: 16.9.6, 16.10.4 or 16.11.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-2829 being exploited?

There is no known exploitation of CVE-2024-2829 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-2829, GHSA-c2wf-8j59-jjhc, UBUNTU-CVE-2024-2829.

Is CVE-2024-2829 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free