# CVE-2024-28593: Cross-site Scripting in Moodle Chat

> Students can inject malicious HTML or images in Moodle Chat, potentially causing code execution or performance degradation.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Mar 2024
- **Updated:** 5 Nov 2024
- **Also known as:** BIT-moodle-2024-28593, GHSA-f6mh-79vh-2hv7, UBUNTU-CVE-2024-28593

## What is CVE-2024-28593?

CVE-2024-28593 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Chat activity in Moodle 4.3.3 allows students to insert a potentially unwanted HTML A element or IMG element, or HTML content that leads to a performance degradation. NOTE: the vendor's Using_Chat page says "If you know some HTML code, you can use it in your text to do things like insert images, play sounds or create different coloured and sized text." This page also says "Chat is due to be removed from standard Moodle."

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-28593?

3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions to 4.3.3 | None |
| `moodle/moodle` | Packagist | All versions to 4.3.3 | None |
| `moodle` | Bitnami | From 4.3.3 | 4.3.4 |

Products: Moodle Moodle.

## How do I fix CVE-2024-28593?

Apply the vendor's patch.

## Is CVE-2024-28593 being exploited?

There is no known exploitation of CVE-2024-28593 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28593 and fix it if it is affected.

What it is: CVE-2024-28593 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-28593 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions up to 4.3.3; no fix listed
- moodle/moodle (Packagist): affected all versions up to 4.3.3; no fix listed
- moodle (Bitnami): affected from 4.3.3; fixed in 4.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28593/ (Markdown: https://insights.sbomify.com/CVE-2024-28593/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28593
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28593
- OSV: https://osv.dev/vulnerability/CVE-2024-28593

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28593/
Summaries are generated and may contain mistakes; the official description above is the record.
